Bug 446329 - Built-in Astronomical and Holidays calendar share same event, which may be shown not at all, once or twice
Summary: Built-in Astronomical and Holidays calendar share same event, which may be sh...
Status: RESOLVED DUPLICATE of bug 445324
Alias: None
Product: plasmashell
Classification: Plasma
Component: Calendar (show other bugs)
Version: 5.23.4
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-12-01 16:15 UTC by postix
Modified: 2021-12-01 20:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description postix 2021-12-01 16:15:43 UTC
SUMMARY
Depending on how you set the checkboxes you either see the event "December Solstice" on Dec 21st not at all, once or twice.

STEPS TO REPRODUCE
1) 

[ ] Astronomical Events
[ ] Holidays

Dec 21: No events

2) 

[ ] Astronomical Events
[x] Holidays

Dec 21: December Solstice


3) 

[ ] Astronomical Events
[x] Holidays

Dec 21: December Solstice

3) 

[x] Astronomical Events
[ ] Holidays

[x] Lunar Phases
[x] Astronomical seasons

Dec 21: No events

4) 

[ ] Astronomical Events (apply) then [x] Astronomical Events (apply)
[ ] Holidays

[x] Lunar Phases
[x] Astronomical seasons

Dec 21: December Solstice

5) 

[x] Astronomical Events
[x] Holidays

[x] Lunar Phases
[x] Astronomical seasons

Dec 21: December Solstice shown twice


SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20211129
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
No further calendars involved. All calendars came shipped built-in.
Comment 1 Nate Graham 2021-12-01 20:56:05 UTC

*** This bug has been marked as a duplicate of bug 445324 ***