Bug 446303 - [Touch input] Checkboxes in most widgets don't toggle when tapped
Summary: [Touch input] Checkboxes in most widgets don't toggle when tapped
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.88.0
Platform: Manjaro Linux
: VHI normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords: regression
: 449014 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-12-01 00:09 UTC by personalizedrefrigerator
Modified: 2022-01-23 23:57 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.91


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description personalizedrefrigerator 2021-12-01 00:09:22 UTC
SUMMARY

Checkboxes in most widgets do not respond to touch input.

STEPS TO REPRODUCE
1. Open the "battery" applet
2. Tap on "Inhibit Automatic Screen Sleeping and Locking"
3. Open the "audio" applet
4. Tap on the "raise maximum volume" checkbox
5. Open the "screen layout applet"
6. Tap on the "enable presentation mode" checkbox

OBSERVED RESULT
The checkboxes (except for in step 6) do not toggle when tapped -- only the "enable presentation mode" checkbox responds to touch input.

EXPECTED RESULT
Tapping on a checkbox should toggle it in all cases.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Wayland/Fedora 35, Wayland/Manjaro
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0, 5.89.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
I've only tested this on Wayland.
Comment 1 Nate Graham 2021-12-01 02:09:19 UTC
Can confirm. I'm pretty sure this used to work. Will try to bisect soon.
Comment 2 Nate Graham 2021-12-01 02:59:05 UTC
Can't bisect easily because old plasma framework doesn't work with new plasmashell...
Comment 3 Sönke Holz 2021-12-14 14:05:39 UTC
I also noticed this bug.
After a bit of manual bisecting (Are you able to git bisect a single file?) I think I found the commit that caused this bug:
It looks like https://invent.kde.org/frameworks/plasma-framework/-/commit/88ca22025997bba602b8cb796a9b79b6da3ffe6c introduced this bug in CheckBox.qml. Revisions before this commit seem to work correctly.
Comment 4 Nate Graham 2021-12-14 17:02:10 UTC
Noah, could you take a look?
Comment 5 Bug Janitor Service 2022-01-20 13:45:29 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/436
Comment 6 Arjen Hiemstra 2022-01-20 14:37:02 UTC
Git commit a83321120e39a78d270607547da54b93e67bbd88 by Arjen Hiemstra.
Committed on 20/01/2022 at 14:05.
Pushed by ngraham into branch 'master'.

Do not use Control for PC3::IconLabel

This results in a control nested in a control and prevents certain
events (like touch tap) from being properly handled by the actual
control.
Related: bug 445899
FIXED-IN: 5.91

M  +27   -4    src/declarativeimports/plasmacomponents3/private/IconLabel.qml

https://invent.kde.org/frameworks/plasma-framework/commit/a83321120e39a78d270607547da54b93e67bbd88
Comment 7 Zamundaaa 2022-01-23 23:57:15 UTC
*** Bug 449014 has been marked as a duplicate of this bug. ***