Bug 446206 - Buttons with linked stying do not appear linked
Summary: Buttons with linked stying do not appear linked
Status: RESOLVED FIXED
Alias: None
Product: Breeze
Classification: Unclassified
Component: gtk theme (show other bugs)
Version: 5.22.5
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Jan Blackquill
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-28 17:34 UTC by krir17.890
Modified: 2021-12-13 16:44 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments
Comparison between linked buttons in breeze0gtk and adwaita (57.93 KB, image/png)
2021-11-28 17:34 UTC, krir17.890
Details

Note You need to log in before you can comment on or make changes to this bug.
Description krir17.890 2021-11-28 17:34:09 UTC
Created attachment 144041 [details]
Comparison between linked buttons in breeze0gtk and adwaita

SUMMARY
Buttons in a GtkBox with "linked" class appear as separate button instead of being linked. (This seems to be the behavior defined in https://invent.kde.org/plasma/breeze-gtk/-/blob/master/src/gtk3/widgets/_button.scss#L410). Ideally they should appear as a set of connected buttons.

STEPS TO REPRODUCE
1. Open Gtk3-widget-factory

OBSERVED RESULT
Widgets such as comboboxentry do not appear as expected (with linked buttons) (see attachment)

EXPECTED RESULT
Linked Buttons should appear connected

SOFTWARE/OS VERSIONS
Breeze-Gtk-version:  5.22.5-0ubuntu1 (installed on Xubuntu 20.04 using deb package)
Comment 1 Bug Janitor Service 2021-12-03 02:03:49 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/breeze-gtk/-/merge_requests/33
Comment 2 Jan Blackquill 2021-12-13 16:44:13 UTC
Git commit d66e5f52b6af0c311f064471362b6ad5b76c95a4 by Jan Blackquill.
Committed on 12/12/2021 at 22:32.
Pushed by ngraham into branch 'master'.

gtk3, gtk4: make linked buttons look linked

M  +61   -129  src/gtk3/widgets/_button.scss
M  +3    -0    src/gtk3/widgets/_headerbar.scss
M  +1    -3    src/gtk3/widgets/_notebook.scss
M  +1    -3    src/gtk3/widgets/_sidebar.scss
M  +61   -129  src/gtk4/widgets/_button.scss
M  +3    -0    src/gtk4/widgets/_headerbar.scss
M  +1    -3    src/gtk4/widgets/_notebook.scss
M  +1    -3    src/gtk4/widgets/_sidebar.scss

https://invent.kde.org/plasma/breeze-gtk/commit/d66e5f52b6af0c311f064471362b6ad5b76c95a4