Bug 446185 - OSDs shown without the level indicator when the screen is locked
Summary: OSDs shown without the level indicator when the screen is locked
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Theme - Breeze (show other bugs)
Version: 5.23.3
Platform: Other Other
: HI minor
Target Milestone: 1.0
Assignee: visual-design
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-11-28 08:47 UTC by Kishore Gopalakrishnan
Modified: 2022-05-02 13:36 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.5


Attachments
OSD when the screen is locked (63.33 KB, image/png)
2021-11-28 08:47 UTC, Kishore Gopalakrishnan
Details
(expected behaviour) OSD when the screen is unlocked (113.94 KB, image/png)
2021-11-28 08:47 UTC, Kishore Gopalakrishnan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kishore Gopalakrishnan 2021-11-28 08:47:06 UTC
Created attachment 144022 [details]
OSD when the screen is locked

SUMMARY
The volume/brightness OSDs are shown without the horizontal 'level indicator bar' when the screen is locked (see attached screenshots).

STEPS TO REPRODUCE
1. Lock screen
2. Change screen brightness or volume using keyboard keys

OBSERVED RESULTS
The OSD doesn't display the horizontal bar that indicates the current level (see attachment screen_locked.png). It only shows a 'speaker'/'monitor' icon and the numerical percentage.

EXPECTED RESULTS
OSD should look the same as when the screen is unlocked (see attachment screen_unlocked.png).

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 5.10.82-1-lts (64-bit)
Graphics Platform: X11
Processors: 4 × AMD EPYC-Rome Processor
Memory: 1.4 GiB of RAM
Graphics Processor: virgl

ADDITIONAL INFORMATION
Also reproducible with the Oxygen theme, so I am not sure if this is the right component to report it under.
Comment 1 Kishore Gopalakrishnan 2021-11-28 08:47:49 UTC
Created attachment 144023 [details]
(expected behaviour) OSD when the screen is unlocked
Comment 2 Nate Graham 2021-11-29 17:58:33 UTC
Can reproduce. Very interesting.

Actually the bar is visible, but it's getting displayed at 0 width for some reason. That's what the little X in your screenshot is all about.
Comment 3 Nate Graham 2021-11-29 22:29:54 UTC
Caused by https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/4.
Comment 4 ratijas 2022-05-02 10:25:35 UTC
Git commit 2861d1fca3361d3617b2c8d84c91942c0dbc33ed by ivan tkachenko.
Committed on 02/05/2022 at 10:07.
Pushed by ratijas into branch 'master'.

[lookandfeel] Fix collapsed width of a volume/brightness OSD on a lock screen

Amends c067d4985a49cdef8ed0d96ba8019a7b945b1741.

Having `preferredWidth: 1` set on an only item that also stretches with
fillWidth AND without top-to-bottom sizing (fixed size imposed by
parent component) doesn't really make sense. It naturally increased row
layout's implicitWidth by only 1, and that value were used as an input
to the final width expression (bottom-up sizing).

This patch fixes the sizing model to be strictly implicit bottom-up and
explicit top-down, and so the slider no longer collapses.

M  +1    -1    lookandfeel/contents/osd/OsdItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/2861d1fca3361d3617b2c8d84c91942c0dbc33ed
Comment 5 ratijas 2022-05-02 11:01:23 UTC
Git commit b6d5966ce31adaec1ec96499b59d348d5d4743f4 by ivan tkachenko.
Committed on 02/05/2022 at 10:31.
Pushed by ratijas into branch 'Plasma/5.24'.

[lookandfeel] Fix collapsed width of a volume/brightness OSD on a lock screen

Amends c067d4985a49cdef8ed0d96ba8019a7b945b1741.

Having `preferredWidth: 1` set on an only item that also stretches with
fillWidth AND without top-to-bottom sizing (fixed size imposed by
parent component) doesn't really make sense. It naturally increased row
layout's implicitWidth by only 1, and that value were used as an input
to the final width expression (bottom-up sizing).

This patch fixes the sizing model to be strictly implicit bottom-up and
explicit top-down, and so the slider no longer collapses.

(cherry picked from commit 2861d1fca3361d3617b2c8d84c91942c0dbc33ed)

M  +1    -1    lookandfeel/contents/osd/OsdItem.qml

https://invent.kde.org/plasma/plasma-workspace/commit/b6d5966ce31adaec1ec96499b59d348d5d4743f4