Bug 446105 - Toggling "Only group when Task Manager is full" will make the height of textual list 1px
Summary: Toggling "Only group when Task Manager is full" will make the height of textu...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: master
Platform: openSUSE RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-26 08:15 UTC by Fushan Wen
Modified: 2021-11-29 20:05 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Bug.mp4 (1.04 MB, video/mp4)
2021-11-26 12:43 UTC, Fushan Wen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fushan Wen 2021-11-26 08:15:24 UTC
SUMMARY
Similar to https://bugs.kde.org/show_bug.cgi?id=445848

STEPS TO REPRODUCE
1. Restart plasmashell
2. Enter Edit Mode
3. Edit Task Manager and enable "Only group when Task Manager is full", then apply.
4. Edit Task Manager and disable "Only group when Task Manager is full", then apply.
5. Exit Edit Mode

OBSERVED RESULT
The height of textual list becomes 1px

EXPECTED RESULT
Normal height

SOFTWARE/OS VERSIONS
X11
Comment 1 Fushan Wen 2021-11-26 08:44:11 UTC
I find out the real cause: groupDialog.visualParent.itemIndex is not updated if the index of a task is changed.
Comment 2 Bug Janitor Service 2021-11-26 09:44:14 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/716
Comment 3 Fushan Wen 2021-11-26 12:43:25 UTC
Created attachment 143964 [details]
Bug.mp4
Comment 4 Nate Graham 2021-11-29 20:05:48 UTC
Git commit 05efb051608d7f3467c1fb5e0510d7de13ca6dbc by Nate Graham, on behalf of Fushan Wen.
Committed on 29/11/2021 at 20:00.
Pushed by ngraham into branch 'master'.

taskmanager: Replace count with groupFilter.count for groupListView

Use groupFilter.count because sometimes groupFilter.count is updated in
time but count is not, so no more 1px bug will occur again.

M  +2    -1    applets/taskmanager/package/contents/ui/GroupDialog.qml

https://invent.kde.org/plasma/plasma-desktop/commit/05efb051608d7f3467c1fb5e0510d7de13ca6dbc