Bug 445946 - Weather applet offers to open Kate
Summary: Weather applet offers to open Kate
Status: RESOLVED FIXED
Alias: None
Product: kdeplasma-addons
Classification: Unclassified
Component: Weather (show other bugs)
Version: master
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-22 22:21 UTC by Nicolas Fella
Modified: 2021-11-29 16:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments
Screenshot (11.63 KB, image/png)
2021-11-22 22:21 UTC, Nicolas Fella
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas Fella 2021-11-22 22:21:47 UTC
Created attachment 143851 [details]
Screenshot

STEPS TO REPRODUCE
1. Enable the weather applet 
2. Add a city (using wettercom)
3. Right-click on the applet in the system tray

OBSERVED RESULT
A menu entry that says "Open with Kate". When clicked Firefox opens wetter.com

EXPECTED RESULT
The entry says something like "Open with Firefox" (my default browser)

SOFTWARE/OS VERSIONS
Everything master
Comment 1 Nicolas Fella 2021-11-22 22:25:51 UTC
The entry does not come from the applet directly but rather through the associated application manager stuff in plasma-framework

It looks like it's suggesting the app based on mime type of the url, which is application/octet-stream for http://wetter.com
Comment 2 Bug Janitor Service 2021-11-22 23:50:23 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kdeplasma-addons/-/merge_requests/101
Comment 3 Nicolas Fella 2021-11-29 12:07:39 UTC
Git commit a994464a71c767cd8d613c98378cdb9f25c4017d by Nicolas Fella.
Committed on 29/11/2021 at 12:03.
Pushed by nicolasfella into branch 'master'.

[applets/weather] Remove associatedApplicationUrls

This removes the 'Open in ' entry from the applet's context menu

It's somewhat broken and not particularly useful since it just opens a static site in the browser

The same site is already available from the main UI

M  +0    -1    applets/weather/package/contents/ui/main.qml

https://invent.kde.org/plasma/kdeplasma-addons/commit/a994464a71c767cd8d613c98378cdb9f25c4017d