Bug 445910 - Search uses wrong Kickoff instance
Summary: Search uses wrong Kickoff instance
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.3
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-22 07:47 UTC by Ian
Modified: 2021-11-23 17:56 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
video of the problem (2.29 MB, video/webm)
2021-11-22 07:47 UTC, Ian
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ian 2021-11-22 07:47:49 UTC
Created attachment 143827 [details]
video of the problem

SUMMARY
When using more than 1 instance of Kickoff (for example with multiple monitors or 2 panels on 1 monitor), typing to search inputs the text in the most recent instance of kickoff that a search was done in, not the currently open instance.

STEPS TO REPRODUCE
1. Have 2 instances of Kickoff present on 1 desktop
2. Open the first instance and type something to search for.
3. Open the the second instance and type something to search for.
4. Re-open the first instance

OBSERVED RESULT
The first instance works normally, but typing in the second instance, no text appears.
Re-opening the first instance, the text typed in the second instance appears in the search bar.
Manually clicking the search bar and typing works normally if all instances have been cleared.

EXPECTED RESULT
Opening any instance of kickoff and typing results in a new search in that instance.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
(available in About System)
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Tried removing ~/.config/plasma-org.kde.plasma.desktop-appletsrc
but still persisting.
Comment 1 Paul Worrall 2021-11-22 10:23:29 UTC
Can reproduce with two Application Launchers in the same panel

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-40-generic (64-bit)
Graphics Platform: Wayland
Processors: 2 × AMD A6-6400K APU with Radeon(tm) HD Graphics
Memory: 7.7 GiB of RAM
Graphics Processor: AMD CEDAR
Comment 2 Nate Graham 2021-11-23 17:56:27 UTC

*** This bug has been marked as a duplicate of bug 443131 ***