Bug 445901 - Show context menu on touch press-and-hold
Summary: Show context menu on touch press-and-hold
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.23.3
Platform: Fedora RPMs Linux
: NOR wishlist
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-11-22 07:13 UTC by personalizedrefrigerator
Modified: 2022-02-17 23:48 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description personalizedrefrigerator 2021-11-22 07:13:17 UTC
SUMMARY
A long tap on items in the task manager (Icons-Only Task Manager) should open the context menu for that item. Without this context menu, users cannot easily remove an item from favorites.


STEPS TO REPRODUCE
1. Tap and hold on an icon in the task manager

OBSERVED RESULT
The icon activates as if left-clicked.

EXPECTED RESULT
The context/right-click menu should be shown.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Fedora 35, Wayland
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Only tested on Wayland.
Comment 1 Nate Graham 2021-11-23 17:32:07 UTC
Works for me on Wayland; cannot reproduce.
Comment 2 personalizedrefrigerator 2021-11-24 13:43:06 UTC
I can also reproduce this on Manjaro/Plasma 5.23.3. I am not running touchegg (a possible cause for not being to able to be reproduced?).
Comment 3 Nate Graham 2021-11-24 20:33:30 UTC
Neither am I.
Comment 4 Patrick Silva 2022-02-17 12:45:22 UTC
Can reproduce on neon unstable. I can't remove apps pinned to icon-only or classic task managers using my touchscreen.

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.92.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 5 Nate Graham 2022-02-17 18:33:18 UTC
I think I was testing the wrong thing before.

Indeed, the task manager doesn't show a context menu on press-and-hold the way Kickoff does.
Comment 6 Bug Janitor Service 2022-02-17 22:27:55 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/847
Comment 7 Nate Graham 2022-02-17 23:48:47 UTC
Git commit 355e55ec7df6c4e274eab761b2d7b99c105a7495 by Nate Graham.
Committed on 17/02/2022 at 22:23.
Pushed by ngraham into branch 'master'.

applets/taskmanager: show context menu on press-and-hold

This makes the applet more touch-friendly. Most applets are designed in
such a manner that they don't have any features that can *only* be
accessed from a context menu, but the Task Manager is an exception, and
it's not at all simple to envision how we could move all the items in
the context menu to a visible UI, or if it would even be feasible or
desirable to do so at all.

Thus, let's just show the normal context menu with a press-and-hold.

Code is lifted from Kickoff, including the TODO.
FIXED-IN: 5.25

M  +16   -0    applets/taskmanager/package/contents/ui/Task.qml

https://invent.kde.org/plasma/plasma-desktop/commit/355e55ec7df6c4e274eab761b2d7b99c105a7495