Bug 445605 - PlasmaShell crash after ejecting partially-mounted SD Card (Only 1 of 2 partitions is mounted)
Summary: PlasmaShell crash after ejecting partially-mounted SD Card (Only 1 of 2 parti...
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Disks & Devices (show other bugs)
Version: 5.23.3
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-16 18:54 UTC by xanonix161
Modified: 2021-11-24 04:28 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xanonix161 2021-11-16 18:54:37 UTC
SUMMARY
***
NOTE: If you are reporting a crash, please try to attach a backtrace with debug symbols.
See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports
***


STEPS TO REPRODUCE
1. Insert an SD Card with two partitions
2. Open Disks and Devices applet, and click on one of them to mount and open, leaving the other partition unmounted
3. Close Dolphin, then go back to the applet, and hit the "Safely Remove" button, then remove the SD Card from the computer.

OBSERVED RESULT
Plasmashell crashes and reloads

EXPECTED RESULT
Nothing, applet closes and PC continues operating normally

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux x86_64
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION

The following error is dumped in systemd's logs when plasmashell crashes due to this bug - https://pastebin.com/Vk2GY77m
Comment 1 Nate Graham 2021-11-24 04:28:02 UTC

*** This bug has been marked as a duplicate of bug 427945 ***