Bug 445453 - system settings crash
Summary: system settings crash
Status: RESOLVED DUPLICATE of bug 445432
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: 5.23.3
Platform: Debian unstable Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-11-14 01:52 UTC by danc
Modified: 2021-11-23 18:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description danc 2021-11-14 01:52:46 UTC
Application: systemsettings5 (5.23.3)

Qt Version: 5.15.2
Frameworks Version: 5.88.0
Operating System: Linux 5.14.0-4-amd64 x86_64
Windowing System: X11
Distribution: Debian GNU/Linux bookworm/sid
DrKonqi: 5.23.3 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:
opening system settings

- Custom settings of the application:
using sid

I just updated the system and that is when the crash happened.

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f73d5b337c2 in QV4::QQmlTypeWrapper::virtualInstanceOf(QV4::Object const*, QV4::Value const&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#5  0x00007f73d5a212b7 in QV4::Runtime::Instanceof::call(QV4::ExecutionEngine*, QV4::Value const&, QV4::Value const&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#6  0x00007f73d5a0d295 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007f73d5a11cf7 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007f73d59ad56d in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#9  0x00007f73d5b243c5 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#10 0x00007f73d5b294c4 in QQmlBinding::evaluate(bool*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#11 0x00007f73d5b2d367 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#12 0x00007f73d5b2b144 in QQmlBinding::update(QFlags<QQmlPropertyData::WriteFlag>) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#13 0x00007f73d5b377e3 in QQmlObjectCreator::finalize(QQmlInstantiationInterrupt&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#14 0x00007f73d5acc86c in QQmlComponentPrivate::complete(QQmlEnginePrivate*, QQmlComponentPrivate::ConstructionState*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#15 0x00007f73d5aceafe in QQmlComponentPrivate::completeCreate() () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007f73d5acfbf0 in QQmlComponent::createObject(QQmlV4Function*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#17 0x00007f73d5ad0693 in QQmlComponent::qt_metacall(QMetaObject::Call, int, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#18 0x00007f73d5b086fd in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#19 0x00007f73d59f3ba6 in QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#20 0x00007f73d5a0f1cf in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#21 0x00007f73d5a11cf7 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#22 0x00007f73d59ad56d in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#23 0x00007f73d5b243c5 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#24 0x00007f73d5ad858b in QQmlBoundSignalExpression::evaluate(void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#25 0x00007f73d5ad8a70 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#26 0x00007f73d5b081ad in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#27 0x00007f73d6c6a4dd in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#28 0x00007f73d5b7fcf3 in QQmlTimer::qt_metacall(QMetaObject::Call, int, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#29 0x00007f73d5b086fd in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#30 0x00007f73d59f13ce in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#31 0x00007f73d59f395a in QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#32 0x00007f73d5a0f1cf in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#33 0x00007f73d5a11cf7 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#34 0x00007f73d59ad56d in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#35 0x00007f73d5b243c5 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#36 0x00007f73d5ad858b in QQmlBoundSignalExpression::evaluate(void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#37 0x00007f73d5ad8a70 in ?? () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#38 0x00007f73d5b081ad in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#39 0x00007f73d6c6a4dd in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#40 0x00007f73d5b37ce8 in QQmlObjectCreator::finalize(QQmlInstantiationInterrupt&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#41 0x00007f73d5ad269c in QQmlIncubatorPrivate::incubate(QQmlInstantiationInterrupt&) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#42 0x00007f73d5ad2c27 in QQmlEnginePrivate::incubate(QQmlIncubator&, QQmlContextData*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#43 0x00007f73d5acdc52 in QQmlComponent::create(QQmlIncubator&, QQmlContext*, QQmlContext*) () from /lib/x86_64-linux-gnu/libQt5Qml.so.5
#44 0x00007f73d62225da in KDeclarative::QmlObject::completeInitialization(QHash<QString, QVariant> const&) () from /lib/x86_64-linux-gnu/libKF5Declarative.so.5
#45 0x00007f73d81b2476 in KQuickAddons::ConfigModule::mainUi() () from /lib/x86_64-linux-gnu/libKF5QuickAddons.so.5
#46 0x00007f73d82c4ab9 in KCModuleLoader::loadModule(KCModuleInfo const&, KCModuleLoader::ErrorReporting, QWidget*, QStringList const&) () from /lib/x86_64-linux-gnu/libKF5KCMUtils.so.5
#47 0x00007f73d82cfb45 in ?? () from /lib/x86_64-linux-gnu/libKF5KCMUtils.so.5
#48 0x00007f73d82d0808 in KCModuleProxy::realModule() const () from /lib/x86_64-linux-gnu/libKF5KCMUtils.so.5
#49 0x00007f73d830df92 in ModuleView::updatePageIconHeader(KPageWidgetItem*, bool) () from /lib/x86_64-linux-gnu/libsystemsettingsview.so.3
#50 0x00007f73d830f44c in ModuleView::addModule(KCModuleInfo*, QStringList const&) () from /lib/x86_64-linux-gnu/libsystemsettingsview.so.3
#51 0x00007f73b595495f in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/systemsettingsview/systemsettings_sidebar_mode.so
#52 0x00007f73b5954db9 in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/systemsettingsview/systemsettings_sidebar_mode.so
#53 0x00005596394354b5 in ?? ()
#54 0x00005596394381df in ?? ()
#55 0x00007f73d6c6078c in QObject::event(QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#56 0x00007f73d826d557 in KXmlGuiWindow::event(QEvent*) () from /lib/x86_64-linux-gnu/libKF5XmlGui.so.5
#57 0x00007f73d782d74f in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Widgets.so.5
#58 0x00007f73d6c33e9a in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#59 0x00007f73d6c36e11 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#60 0x00007f73d6c8c413 in ?? () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#61 0x00007f73d4754c7b in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#62 0x00007f73d4754f28 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#63 0x00007f73d4754fdf in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#64 0x00007f73d6c8ba90 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#65 0x00007f73d6c328db in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#66 0x00007f73d6c3ab10 in QCoreApplication::exec() () from /lib/x86_64-linux-gnu/libQt5Core.so.5
#67 0x0000559639431e30 in ?? ()
#68 0x00007f73d65dbe4a in __libc_start_main () from /lib/x86_64-linux-gnu/libc.so.6
#69 0x0000559639432b5a in ?? ()
[Inferior 1 (process 4505) detached]

The reporter indicates this bug may be a duplicate of or related to bug 445432.

Possible duplicates by query: bug 445432, bug 445430, bug 445386, bug 445025, bug 444877.

Reported using DrKonqi
Comment 1 Nate Graham 2021-11-23 18:46:38 UTC

*** This bug has been marked as a duplicate of bug 445432 ***