Bug 445371 - After a fresh install of Arch Linux and KDE the search field in the Application Launcher is only working until a reboot.
Summary: After a fresh install of Arch Linux and KDE the search field in the Applicati...
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Plasma
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.3
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-12 09:37 UTC by detzi
Modified: 2021-11-12 22:58 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Skript that i used to install arch (13.77 KB, application/x-shellscript)
2021-11-12 09:37 UTC, detzi
Details
Application Launcher (not) showing search result (12.16 KB, image/png)
2021-11-12 09:48 UTC, detzi
Details
Krunner Settings (91.89 KB, image/png)
2021-11-12 09:48 UTC, detzi
Details
Krunner itself works (78.37 KB, image/png)
2021-11-12 09:49 UTC, detzi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description detzi 2021-11-12 09:37:58 UTC
Created attachment 143476 [details]
Skript that i used to install arch

SUMMARY
After a fresh install of Arch Linux and KDE the search field in the Application Launcher is only working until a reboot. When i open krunner itself it works and when i remove the current panel and add a new one the issue is fixed (cursor active in search and can find stuff) but only until i reboot, after that it's broken again.

STEPS TO REPRODUCE
1. Install ArchLinux with provided skript
2. reboot
3. LogIn
4. Open Application Launcher with the super key 
optional:
5. remove current Panel
6. add a default Panel (temporarily fixes the issue)
7. reboot
8. Issues appears again

OBSERVED RESULT
1. Cursor is not active in the search field
2. Search Terms do not return results

EXPECTED RESULT
1. Cursor is active in the search field
2. Search Terms do return results

SOFTWARE/OS VERSIONS
Operating System: Arch Linux
KDE Plasma Version: 5.23.3
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.16-arch1-1 (64-bit)
Graphics Platform: X11

ADDITIONAL INFORMATION
Comment 1 detzi 2021-11-12 09:48:22 UTC
Created attachment 143478 [details]
Application Launcher (not) showing search result
Comment 2 detzi 2021-11-12 09:48:48 UTC
Created attachment 143479 [details]
Krunner Settings
Comment 3 detzi 2021-11-12 09:49:35 UTC
Created attachment 143480 [details]
Krunner itself works
Comment 4 detzi 2021-11-12 10:44:12 UTC
I noticed that when i do the above, hit the super key (opens the application launcher on my primary display)and start writing a search term it is not put into the search field, but if i then open the application launcher on my second screen the text i just typed got instead inserted in its search field. Which then also works as expected.

To get around this i bound the hotkey ALT+F1 to the application launcher that had the text inserted. Now when hitting "super" the application launcher works as expected.

But when i open the Application launcher on my "primary display" per "mouse click" it still inserts its text into the wrong "Application launcher" and when shows the behavior  as described in the issue description
Comment 5 Nate Graham 2021-11-12 22:58:05 UTC
Same root cause as Bug 443131.

*** This bug has been marked as a duplicate of bug 443131 ***