Bug 445247 - Plasmashell crashes when unmounting a mounted USB.
Summary: Plasmashell crashes when unmounting a mounted USB.
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Disks & Devices (show other bugs)
Version: 5.23.3
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-10 06:46 UTC by Samuel
Modified: 2021-11-10 17:01 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel 2021-11-10 06:46:14 UTC
SUMMARY
    Plasmashell crashes when I unmount a USB by using "Safely Remove" option from System Tray applet.

STEPS TO REPRODUCE
1.  Insert a USB and mount it.
2.  Unmount the mounted USB by clicking on "Safely Remove" option in System Tray applet.
3.  See the plasmashell crash and restart itself.

OBSERVED RESULT
    When I unmount a mounted USB, the systray applet shows that the USB has been safely removed and then crashes and replaces itself. Plasmashell doesnt crash after unmounting the USB sometimes, so by doing it repeatedly, this issue would appear.

EXPECTED RESULT
    Unmounting a USB shouldn't result in a plasmashell crash.

SOFTWARE/OS VERSIONS
OS, Kernel: Arch Linux (all up-to-date), linux-tkg-pds-5.15.0-214 & linux-zen-5.14 (changing kernel doesn't make any difference)
KDE Plasma: 5.23.2 
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
GPU: NVIDIA GeForce GTX 1060 6GB
Driver: NVIDIA Proprietary Driver 495.44

Here is a video of this issue:- https://youtu.be/WfIZxLBrRLE
Comment 1 Samuel 2021-11-10 14:09:16 UTC
Closing this bug report as I have found another one thats more detailed than mine.
Comment 2 Samuel 2021-11-10 14:09:31 UTC

*** This bug has been marked as a duplicate of bug 445231 ***
Comment 3 Nate Graham 2021-11-10 17:01:40 UTC

*** This bug has been marked as a duplicate of bug 427945 ***