Bug 445157 - KRunner always opens on a particular screen in Wayland (unlike X11, where it opens where the mouse is)
Summary: KRunner always opens on a particular screen in Wayland (unlike X11, where it ...
Status: RESOLVED DUPLICATE of bug 427069
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: 5.23.2
Platform: OpenSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-11-08 13:17 UTC by phrxmd
Modified: 2022-03-27 11:33 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description phrxmd 2021-11-08 13:17:44 UTC
SUMMARY
On Wayland, KRunner always opens on a particular screen, when in X11 it opens on the screen with the mouse pointer.

STEPS TO REPRODUCE
1. In the Wayland session, with multiple monitors, invoke KRunner.
2. Move the mouse pointer to another monitor and invoke KRunner again.

OBSERVED RESULT
KRunner always opens on a particular screen - in my case my notebook's screen, which happens to be the leftmost screen.

EXPECTED RESULT
KRunner should open on the screen where the mouse pointer is, like it does on X11.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20211105
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.14-1-default (64-bit)
Graphics Platform: Wayland
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 15.5 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics 620

ADDITIONAL INFORMATION
Comment 1 Firlaev-Hans 2021-11-13 17:09:12 UTC
Can confirm on Arch Linux (Plasma 5.23.3) as well as KDE Neon unstable, Krunner always opens on the left screen even if the cursor is on the right screen.
Comment 2 phrxmd 2022-02-09 22:54:27 UTC
Still happens with KRunner 5.90.0 on Plasma 5.24.0.
Comment 3 ilker 2022-02-15 08:21:19 UTC
Can confirm that it doesn't working on Kde Neon with 5.24.0
Comment 4 Kishore Gopalakrishnan 2022-03-27 11:33:50 UTC

*** This bug has been marked as a duplicate of bug 427069 ***