Bug 445066 - when installing global themes the system setting crashes
Summary: when installing global themes the system setting crashes
Status: RESOLVED DUPLICATE of bug 439797
Alias: None
Product: systemsettings
Classification: Applications
Component: generic-crash (show other bugs)
Version: 5.23.2
Platform: Archlinux Linux
: NOR crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-06 10:32 UTC by prinon
Modified: 2021-11-08 21:52 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
the system settings crash report (.kcrash) (3.44 KB, text/vnd.kde.kcrash-report)
2021-11-06 10:32 UTC, prinon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description prinon 2021-11-06 10:32:34 UTC
Created attachment 143275 [details]
the system settings crash report (.kcrash)

SUMMARY
when trying to install new global themes from the system settings app the process of installing takes long and after that the system settings app crashes. After restarting the system settings app the new global themes appears in the Global Theme menu.

STEPS TO REPRODUCE
1. open `Get New Global Themes`
2. choose and install, for example, qogir theme, Arc Dark, Ant-Dark, Layan, 
3. after a long-ish perioad when the system settings app shows that the new global theme in installing (cog icons rotates) then the system settings app crashes.

OBSERVED RESULT
every time I try to install a new Global Theme the system settings app crashes

EXPECTED RESULT
system settings app crashes

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Archlinux
(available in About System)
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-11-08 21:38:49 UTC
Unfortunately the backtrace is incomplete and missing debug symbols that we need to figure out exactly what's going wrong:


#4  0x00007f2b5a790859 in QDir::fromNativeSeparators(QString const&) () at /usr/lib/libQt5Core.so.5
#5  0x00007f2b5a7a4907 in QFileInfo::QFileInfo(QString const&) () at /usr/lib/libQt5Core.so.5
#6  0x00007f2ae839aed7 in  () at /usr/lib/qt/plugins/kcms/kcm_lookandfeel.so
#7  0x00007f2ae8398a0b in  () at /usr/lib/qt/plugins/kcms/kcm_lookandfeel.so
#8  0x00007f2b5970bc9e in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007f2b595e7121 in  () at /usr/lib/libQt5Qml.so.5


Could you please install debug symbols for plasma, reproduce the crash, and attach a new symbolicated backtrace? See https://community.kde.org/Guidelines_and_HOWTOs/Debugging/How_to_create_useful_crash_reports#Arch

Thanks!
Comment 2 Nate Graham 2021-11-08 21:52:08 UTC
Actually I managed to figure out from the context that this is Bug 439797.

*** This bug has been marked as a duplicate of bug 439797 ***