Bug 444934 - In multi-monitor configurations, typing is not fed to the open menu
Summary: In multi-monitor configurations, typing is not fed to the open menu
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.2
Platform: Neon Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-11-04 10:07 UTC by Riccardo Robecchi
Modified: 2021-11-08 19:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Riccardo Robecchi 2021-11-04 10:07:29 UTC
SUMMARY
I have two monitors, each with its own panel and its own menu. There are then two menus and the one on the main screen has the meta/Win key shortcut enabled. Since the update to Plasma 5.23.2, opening the menu through the meta key does not focus the search field; instead, the key presses are sent to the other menu, which is closed.

STEPS TO REPRODUCE
1. Open the menu with the meta key
2. Start typing to search

OBSERVED RESULT
The key presses are redirected to the wrong menu.

EXPECTED RESULT
The key presses are received by the active, currently open menu.

SOFTWARE/OS VERSIONS
Linux: KDE neon
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-11-08 19:11:40 UTC

*** This bug has been marked as a duplicate of bug 443131 ***