Bug 444899 - Logout greeter background is solid black
Summary: Logout greeter background is solid black
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-various (show other bugs)
Version: git master
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-11-03 18:11 UTC by Kai Uwe Broulik
Modified: 2021-11-27 05:29 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.23.4


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2021-11-03 18:11:49 UTC
SUMMARY
The logout greeter backgound is solid black as opposed to having a blurred background.

STEPS TO REPRODUCE
1. Leave session

OBSERVED RESULT
Logout greeter background is solid black

EXPECTED RESULT
Logout greeter is gorgeously blurred

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: git master as of 2021-11-01 on X11

ADDITIONAL INFORMATION
Seems unrelated to Bug 444898 as even after fixing the fade animation the background is still black. However, you can see during the animation that it is blurred but seems not visible because of the opaque background it ends up with
Comment 1 Bug Janitor Service 2021-11-25 11:07:01 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/1218
Comment 2 David Edmundson 2021-11-25 11:23:26 UTC
Git commit a7fa01015c99b2fa9e7e15280e7d289766b7932f by David Edmundson.
Committed on 25/11/2021 at 11:22.
Pushed by davidedmundson into branch 'master'.

[logout-greeter] Set window class name

This matches what kwin's effects have always been searching for. It only
used to appear to work as "ksmserver ksmserver" was checked in previous
versions.
Related: bug 444898

M  +2    -2    logout-greeter/shutdowndlg.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/a7fa01015c99b2fa9e7e15280e7d289766b7932f
Comment 3 Nate Graham 2021-11-27 05:28:16 UTC
Git commit 22bd1fb8cbb23e7aeb0237f1389ef35b0553a040 by Nate Graham, on behalf of David Edmundson.
Committed on 27/11/2021 at 05:27.
Pushed by ngraham into branch 'Plasma/5.23'.

[logout-greeter] Set window class name

This matches what kwin's effects have always been searching for. It only
used to appear to work as "ksmserver ksmserver" was checked in previous
versions.
Related: bug 444898
(cherry picked from commit a7fa01015c99b2fa9e7e15280e7d289766b7932f)

M  +2    -2    logout-greeter/shutdowndlg.cpp

https://invent.kde.org/plasma/plasma-workspace/commit/22bd1fb8cbb23e7aeb0237f1389ef35b0553a040