Bug 444810 - Minimize all Windows widget's header bar does not align with the top edge of the Task Manager
Summary: Minimize all Windows widget's header bar does not align with the top edge of ...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Show Desktop/Minimize All (show other bugs)
Version: 5.23.2
Platform: Archlinux Packages Linux
: NOR minor
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
: 446854 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-11-02 08:56 UTC by Matthew Day
Modified: 2022-02-16 15:37 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.2


Attachments
Screenshot of the widget after clicking (3.06 KB, image/png)
2021-11-02 08:56 UTC, Matthew Day
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Day 2021-11-02 08:56:07 UTC
Created attachment 143118 [details]
Screenshot of the widget after clicking

STEPS TO REPRODUCE
1. Add the Minimize all Windows widget to the Task Manager
2. Click the Minimize all Windows widget

OBSERVED RESULT
Header bar appears below the top edge of the Task Manager

EXPECTED RESULT
Header bar aligns with the top edge of the Task Manager

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Comment 1 Nate Graham 2021-11-08 19:22:01 UTC
Can confirm; seems to be an issue in the Widget itself.
Comment 2 Nate Graham 2021-12-14 18:32:50 UTC
*** Bug 446854 has been marked as a duplicate of this bug. ***
Comment 3 Nate Graham 2022-02-16 15:35:38 UTC
Git commit 2555e8d03da2d3754cc8387557063defc1c236b2 by Nate Graham.
Committed on 16/02/2022 at 15:34.
Pushed by ngraham into branch 'master'.

applets/minimizeall: make active indicator line touch panel edges
FIXED-IN: 5.24.2

M  +21   -2    applets/minimizeall/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/2555e8d03da2d3754cc8387557063defc1c236b2
Comment 4 Nate Graham 2022-02-16 15:37:22 UTC
Git commit b56519113f50fc707853fa2c5456b5e15789744a by Nate Graham.
Committed on 16/02/2022 at 15:37.
Pushed by ngraham into branch 'Plasma/5.24'.

applets/minimizeall: make active indicator line touch panel edges
FIXED-IN: 5.24.2
(cherry picked from commit 2555e8d03da2d3754cc8387557063defc1c236b2)

M  +21   -2    applets/minimizeall/package/contents/ui/main.qml

https://invent.kde.org/plasma/plasma-desktop/commit/b56519113f50fc707853fa2c5456b5e15789744a