Bug 444692 - Cursor moves to another section after identifying or ignoring face
Summary: Cursor moves to another section after identifying or ignoring face
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Applications
Component: Faces-Workflow (show other bugs)
Version: 7.4.0
Platform: Microsoft Windows Microsoft Windows
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
: 445694 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-31 00:14 UTC by Kristian
Modified: 2022-01-08 05:24 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.5.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kristian 2021-10-31 00:14:43 UTC
SUMMARY
Cursor moves to another section after identifying or ignoring face

STEPS TO REPRODUCE
1. Generally in In People Section of "People" but can also happen in a big list in any other Tagged Person, click a face and assign the Tag name, or idenify as Ignored.
2. It seems that often, possible for KNOWN faces, the "cursor" jumps to the section where the face "moves" to (that is known and has just been identified or ignored) i.e. the cursor does not STAY in the "People" section or the persons section that you are in, so that you can just continue to identify (or ignore) faces.
3. This is frustrating when you have a BIG layout of faces in People, as you always have to scroll back down and find the People Section again. 

OBSERVED RESULT
Cursor moves out of section after identification

EXPECTED RESULT
Cursor stays IN same section after identification; and just goes to next photo left or right of the one that "moved" to the identified section.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
NIL
Comment 1 Maik Qualmann 2021-10-31 06:12:42 UTC
If the problem occurs, is the face detection/recognition still running?

Maik
Comment 2 Kristian 2021-10-31 06:31:04 UTC
(In reply to Maik Qualmann from comment #1)
> If the problem occurs, is the face detection/recognition still running?
> 
> Maik

No. It happens after the Engine has stopped doing the recognising.

After which, I start saying yes to people recognised or adding a name tag to false positives or in People where I (also) say ignored (which is, where I understand, the ONLY  place where "Ignored" works). Thank you!
Comment 3 Serkan 2021-11-02 20:33:00 UTC
I noticed this issue as well, and it's annoying as hell :D

I suspect DigiKam internally goes to the next face on the image, which (obviously) is a different person. Which is nice if I'm looking at the image itself, so I can just type names one after another. But in the overview it's annoying.
Comment 4 Maik Qualmann 2021-11-18 13:01:00 UTC
*** Bug 445694 has been marked as a duplicate of this bug. ***
Comment 5 Maik Qualmann 2022-01-07 22:11:17 UTC
Fixed with this merge request from Philip Gouverneur:

https://invent.kde.org/graphics/digikam/-/commit/6836a0f4399de081f1bd42f01da94a5220ca9086

Maik
Comment 6 Kristian 2022-01-08 05:24:23 UTC
(In reply to Maik Qualmann from comment #5)
> Fixed with this merge request from Philip Gouverneur:
> 
> https://invent.kde.org/graphics/digikam/-/commit/
> 6836a0f4399de081f1bd42f01da94a5220ca9086
> 
> Maik

Thank you very much Maik, much appreciated.