Bug 444585 - bar chart display style does not show bars when many sensors are used
Summary: bar chart display style does not show bars when many sensors are used
Status: RESOLVED FIXED
Alias: None
Product: plasma-systemmonitor
Classification: Plasma
Component: general (show other bugs)
Version: 5.23.0
Platform: Debian unstable Linux
: NOR normal
Target Milestone: ---
Assignee: KSysGuard Developers
URL:
Keywords:
: 449313 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-29 06:54 UTC by john Terragon
Modified: 2022-02-11 16:55 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments
screenshot of bug in widget (71.85 KB, image/png)
2021-12-13 10:11 UTC, darktori
Details

Note You need to log in before you can comment on or make changes to this bug.
Description john Terragon 2021-10-29 06:54:49 UTC
SUMMARY
This affects both the plasma system-monitor app and the plasma widget. I've got a 16C/32T machine so when I use the "Individual core usage" preset I should see 32 bars (duh). Instead no bars are displayed. That seems to be caused by the fact that bars now do not have a minimum width (whereas the widget as a whole seems to have a maximum width). So if you start from one core sensors (or any other sensor) and you keep adding up the other cores one by one you'll see that the bars look fine initially. But then, as you add cores, they get thinner and thinner until they get under one pixel width an then they become invisible.

It used to work in 5.21. But I can't say anything about 5.22 since I use debian and we went from 5.21 to 5.23 directly.


STEPS TO REPRODUCE
1. Simplest way is to use "Individual core usage" widget (or preset) with a machine with 16c/32t
2. Otherwise just start adding sensors (any sensor) to the widget until you get to about 20 and then you'll see non bars anymore.
3. 

OBSERVED RESULT
With a high number of sensors the bars get under one pixel width and therefore they become invisible


EXPECTED RESULT
Bars with a minimum width even with a high number of sensors.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Debian unstable
(available in About System)
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.86
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 mace68 2021-11-09 07:21:31 UTC
(In reply to john Terragon from comment #0)
> SUMMARY
> This affects both the plasma system-monitor app and the plasma widget. I've
> got a 16C/32T machine so when I use the "Individual core usage" preset I
> should see 32 bars (duh). Instead no bars are displayed. That seems to be
> caused by the fact that bars now do not have a minimum width (whereas the
> widget as a whole seems to have a maximum width). So if you start from one
> core sensors (or any other sensor) and you keep adding up the other cores
> one by one you'll see that the bars look fine initially. But then, as you
> add cores, they get thinner and thinner until they get under one pixel width
> an then they become invisible.
> 
> It used to work in 5.21. But I can't say anything about 5.22 since I use
> debian and we went from 5.21 to 5.23 directly.
> 
> 
> STEPS TO REPRODUCE
> 1. Simplest way is to use "Individual core usage" widget (or preset) with a
> machine with 16c/32t
> 2. Otherwise just start adding sensors (any sensor) to the widget until you
> get to about 20 and then you'll see non bars anymore.
> 3. 
> 
> OBSERVED RESULT
> With a high number of sensors the bars get under one pixel width and
> therefore they become invisible
> 
> 
> EXPECTED RESULT
> Bars with a minimum width even with a high number of sensors.
> 
> SOFTWARE/OS VERSIONS
> Windows: 
> macOS: 
> Linux/KDE Plasma: Debian unstable
> (available in About System)
> KDE Plasma Version: 5.23.0
> KDE Frameworks Version: 5.86
> Qt Version: 5.15.2
> 
> ADDITIONAL INFORMATION

I am currently experiencing the exact same behavior in KDE Neon 5.23 User Edition (Plasma v 5.23.2). I can get a maximum of 19 sensor bars to visibly show in "Bar Chart" mode no matter how wide I stretch the widget. At 20+ sensor bars the bars are no longer visible. The issue has definitely been present in all of the 5.23 releases, and I believe the issue was also present in some of the later 5.22 releases if i remember correctly.
Comment 2 mace68 2021-11-09 07:50:22 UTC
(In reply to mace68 from comment #1)
> I am currently experiencing the exact same behavior in KDE Neon 5.23 User
> Edition (Plasma v 5.23.2). I can get a maximum of 19 sensor bars to visibly
> show in "Bar Chart" mode no matter how wide I stretch the widget. At 20+
> sensor bars the bars are no longer visible. The issue has definitely been
> present in all of the 5.23 releases, and I believe the issue was also
> present in some of the later 5.22 releases if i remember correctly.
My current system details:

Operating System: KDE neon 5.23
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3
Kernel Version: 5.11.0-40-generic (64-bit)
Graphics Platform: X11
Processors: 24 × AMD Ryzen 9 5900X 12-Core Processor
Memory: 62.7 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1660 Ti/PCIe/SSE2
Comment 3 darktori 2021-12-13 10:11:54 UTC
Created attachment 144506 [details]
screenshot of bug in widget

I've added a screenshot of the bug. I have a 12C/24T machine, but I'm sure it used to show the bars correctly at some point this year (around spring time?).

As you can see, some cores are used, but no bars are shown. There are some pixels at the very bottom of the chart that might me parts of the bars, but they're too small to tell.
Comment 4 Arjen Hiemstra 2022-01-31 11:33:02 UTC
*** Bug 449313 has been marked as a duplicate of this bug. ***
Comment 5 Bug Janitor Service 2022-02-03 14:31:51 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/libksysguard/-/merge_requests/214
Comment 6 Nate Graham 2022-02-03 17:52:31 UTC
Git commit 17c0b54591aa673dd5096bf4f8a94377315a547d by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 03/02/2022 at 17:48.
Pushed by ngraham into branch 'master'.

BarChart: Make spacing proportional to total width and number of bars

Otherwise we end up with too much spacing and not enough space for the
actual bars, which means we don't show any bars at all.

M  +2    -1    faces/facepackages/barchart/contents/ui/BarChart.qml

https://invent.kde.org/plasma/libksysguard/commit/17c0b54591aa673dd5096bf4f8a94377315a547d
Comment 7 Nate Graham 2022-02-03 17:53:03 UTC
Git commit 11e3696b790016247768d48707914855e991faa7 by Nate Graham, on behalf of Arjen Hiemstra.
Committed on 03/02/2022 at 17:52.
Pushed by ngraham into branch 'Plasma/5.24'.

BarChart: Make spacing proportional to total width and number of bars

Otherwise we end up with too much spacing and not enough space for the
actual bars, which means we don't show any bars at all.


(cherry picked from commit 17c0b54591aa673dd5096bf4f8a94377315a547d)

M  +2    -1    faces/facepackages/barchart/contents/ui/BarChart.qml

https://invent.kde.org/plasma/libksysguard/commit/11e3696b790016247768d48707914855e991faa7
Comment 8 Nate Graham 2022-02-11 16:55:45 UTC
Got a complaint about this; see Bug 449868.