Bug 444482 - Wayland: Spectacle screenshot of window under cursor works via GUI but not in background mode
Summary: Wayland: Spectacle screenshot of window under cursor works via GUI but not in...
Status: RESOLVED DUPLICATE of bug 429390
Alias: None
Product: Spectacle
Classification: Unclassified
Component: General (show other bugs)
Version: 21.08.2
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Boudhayan Gupta
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-10-27 12:52 UTC by chimak111
Modified: 2021-11-15 09:59 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chimak111 2021-10-27 12:52:27 UTC
SUMMARY
With Spectacle 21.08.2 in Wayland, I can capture the window under cursor via the GUI but cannot do so in background mode. 

spectacle -bn -u -o $HOME/Pictures/"$(date +%Y%m%d-%H%M%S)".jpg does nothing (bound to Meta+Ctrl+U).

spectacle -bn -r -o $HOME/Pictures/"$(date +%Y%m%d-%H%M%S)".jpg works (bound to Meta+Ctrl+R).

spectacle -bn -f -o $HOME/Pictures/"$(date +%Y%m%d-%H%M%S)".jpg works (bound to Meta+Ctrl+F).

spectacle -bn -d 10000 -o $HOME/Pictures/"$(date +%Y%m%d-%H%M%S)".jpg works (bound to Meta+Ctrl+D).


EXPECTED RESULT
Using "-u" should work in background mode. Or maybe "spectacle --help" should be modified to indicate which options won't work in Wayland.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE neon
(available in About System)
KDE Plasma Version: 5.23.2
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-11-08 17:14:18 UTC
Can confirm.
Comment 2 Méven Car 2021-11-15 09:59:02 UTC
This one reports the issue for the command line case but the bug origin is the same as the other.

https://bugs.kde.org/show_bug.cgi?id=429390#c9

*** This bug has been marked as a duplicate of bug 429390 ***