Bug 444457 - Can't open remote files via portal dialog; use kio-fuse for this
Summary: Can't open remote files via portal dialog; use kio-fuse for this
Status: RESOLVED FIXED
Alias: None
Product: xdg-desktop-portal-kde
Classification: Plasma
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: HI normal
Target Milestone: ---
Assignee: Jan Grulich
URL:
Keywords:
: 448486 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-10-26 22:12 UTC by Ilya Bizyaev
Modified: 2022-04-02 13:26 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ilya Bizyaev 2021-10-26 22:12:54 UTC
SUMMARY
It would be convenient to be able to interact with remote locations in apps that load xdg-desktop-portal-kde. E.g.:

STEPS TO REPRODUCE
1. With a recent Google Chrome version[1], on any website that asks to upload a file, click the Upload button
2. From KDE's portal file dialog, choose a remote location (they are already listed there anyway)
3. Choose a file from that location

OBSERVED RESULT
The file dialog shows an error message, saying that only local files are supported

EXPECTED RESULT
The file dialog uses kio-fuse to convert that remote path into a local FUSE path and successfully passes that to the application.

ADDITIONAL INFORMATION
[1]: https://chromium-review.googlesource.com/c/chromium/src/+/2992214
Comment 1 Nate Graham 2021-11-08 17:13:27 UTC
+1, would be a good idea.
Comment 2 Nate Graham 2022-01-18 19:35:04 UTC
*** Bug 448486 has been marked as a duplicate of this bug. ***
Comment 3 James C 2022-02-01 15:22:31 UTC
Regular user here, but this would be helpful when working with a NAS on a regular basis. Its the only thing keeping me from switching to KDE as my primary DE.
Thanks for your consideration.
Comment 4 Harald Sitter 2022-03-21 15:02:23 UTC
It occurs to me that we need to ignore scheme support when fuse is present, then compare the selected schemes with the supported schemes, reroute urls as necessary to fuse and then technically things should be amazing.
Comment 5 Nate Graham 2022-04-02 13:26:26 UTC
Fixed by Harald Sitter with https://invent.kde.org/plasma/xdg-desktop-portal-kde/-/commit/bbfa7471d26c84157e6a022b83e202a8de04fee7 in Plasma 5.25!