Bug 444373 - Crash on unmounting last flash drive
Summary: Crash on unmounting last flash drive
Status: RESOLVED DUPLICATE of bug 427945
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Disks & Devices (show other bugs)
Version: 5.22.5
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-25 14:59 UTC by Max
Modified: 2021-10-25 22:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max 2021-10-25 14:59:31 UTC
SUMMARY
plasmashell crashes often (not always) when I unmount last flash drive (i.e. no more disks/partitions remain in "Disks and devices" applet). Crash does not seem to happen if the list is not empty after unmount.

STEPS TO REPRODUCE
1. Mount and then try to unmount the flash drive via applet so the list of disks becomes empty
2. 
3. 

OBSERVED RESULT

Thread 1 "plasmashell" received signal SIGSEGV, Segmentation fault.
QQmlNotifierEndpoint::connect (this=0x556308fc9640, source=0x556305f7bb10, sourceSignal=46, engine=0x0, doNotify=<optimized out>) at qml/qqmlnotifier.cpp:122
122             QObjectPrivate::get(engine)->threadData.loadRelaxed()->threadId.loadRelaxed()) {
(gdb) bt full
#0  QQmlNotifierEndpoint::connect(QObject*, int, QQmlEngine*, bool) (this=0x556308fc9640, source=0x556305f7bb10, sourceSignal=46, engine=0x0, doNotify=<optimized out>)
    at qml/qqmlnotifier.cpp:122
        ddata = <optimized out>
#1  0x00007fc7aaf491f9 in QQmlVMEMetaObjectEndpoint::tryConnect() (this=0x556308fc9640) at qml/qqmlvmemetaobject.cpp:258
        targetDData = <optimized out>
        encodedIndex = {index = <optimized out>}
        coreIndex = 58
        pd = 0x7fc7708a3508
        ctxt = 0x5563048217d0
        target = 0x556305f7bb10
        valueTypeIndex = -1
        aliasData = <optimized out>
        aliasId = <optimized out>
#2  0x00007fc7aaf493c9 in QQmlVMEMetaObject::connectAlias(int) (this=this@entry=0x5563047b9f50, aliasId=aliasId@entry=1) at qml/qqmlvmemetaobject.cpp:1294
        aliasData = <optimized out>
        endpoint = <optimized out>
#3  0x00007fc7aaf4b1b2 in QQmlVMEMetaObject::metaCall(QObject*, QMetaObject::Call, int, void**)
    (this=0x5563047b9f50, o=<optimized out>, c=QMetaObject::ReadProperty, _id=<optimized out>, a=0x7fff6f8a1f60) at qml/qqmlvmemetaobject.cpp:906
        context = <optimized out>
        ctxtPriv = <optimized out>
        targetDData = <optimized out>
        encodedIndex = {index = <optimized out>}
        coreIndex = <optimized out>
        valueTypePropertyIndex = <optimized out>
        aliasData = 0x7fc7091b24f0
        target = 0x556305f7bb10
        id = 1
        propertyCount = <optimized out>
        aliasCount = <optimized out>
        signalCount = <optimized out>
        methodCount = <optimized out>
#4  0x00007fc7aae8ee55 in QQmlPropertyData::readProperty(QObject*, void*) const (property=0x7fff6f8a1f40, target=<optimized out>, this=0x7fc7708a52f8)
    at ../../include/QtQml/5.15.2/QtQml/private/../../../../../src/qml/qml/qqmlpropertydata_p.h:357
        args = {0x7fff6f8a1f40, 0x0}
        v = false
        scope = {engine = 0x556304764280, mark = 0x7fc78d04a550}
#5  loadProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData const&) (v4=0x556304764280, object=0x556305e8e540, property=...) at jsruntime/qv4qobjectwrapper.cpp:152
        v = false
        scope = {engine = 0x556304764280, mark = 0x7fc78d04a550}
#6  0x00007fc7080e8ab3 in  ()
#7  0x00007fff6f8a21b0 in  ()
#8  0x000000000000000a in  ()
#9  0x00007fc7080e87e0 in  ()
#10 0x0000000000000000 in  ()


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Operating System: Fedora 34
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.14.14-200.fc34.x86_64 (64-bit)
Graphics Platform: X11

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-10-25 22:02:07 UTC

*** This bug has been marked as a duplicate of bug 427945 ***