Bug 444349 - Dolphin will copy video files in trash to /tmp
Summary: Dolphin will copy video files in trash to /tmp
Status: RESOLVED DUPLICATE of bug 368104
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 21.08.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-24 20:54 UTC by Eduardo Sánchez Muñoz
Modified: 2021-10-25 00:01 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Eduardo Sánchez Muñoz 2021-10-24 20:54:42 UTC
SUMMARY

Dolphin will copy video files in trash to /tmp, filling it up and possibly leaving the system without free RAM.

STEPS TO REPRODUCE

1. Move a video file to the trash
2. Open the trash in dolphin

OBSERVED RESULT

The file will be copied to /tmp and will be kept there

EXPECTED RESULT

The file should not be copied to /tmp

SOFTWARE/OS VERSIONS

Linux: 5.14.10
(available in About System)
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION

I think the files are copied there to generate the thumbnail, but that is not needed at all. Files in trash are just regular files in ~/.local/share/Trash, so the thumbnailer can just access them normally.
Comment 1 Patrick Silva 2021-10-25 00:01:29 UTC

*** This bug has been marked as a duplicate of bug 368104 ***