Bug 444348 - Double-clicking panel height numbers increases them instead of selecting them
Summary: Double-clicking panel height numbers increases them instead of selecting them
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.87.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-24 20:05 UTC by David
Modified: 2021-10-26 16:39 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.88


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David 2021-10-24 20:05:44 UTC
SUMMARY
If I enter edit mode for a panel and try to select the height numbers by double-clicking them (so as to overwrite them after typing), this double click will not select the numbers, but will instead make the panel bigger.

STEPS TO REPRODUCE
1. Right-click the panel and select edit.
2. Try to double click the px height numbers.

OBSERVED RESULT
Numbers are increased, and do not get selected.

EXPECTED RESULT
Numbers should be selected, and should not be changed.

SOFTWARE/OS VERSIONS
Operating System: Debian GNU/Linux
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.0-3-amd64 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 2700 Eight-Core Processor
Memory: 15.5 GiB of RAM
Graphics Processor: AMD VEGA10

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-10-25 21:29:59 UTC
It's true that double-click doesn't select the number, but I cannot reproduce the size change. I suspect you're actually dragging by accident with the double-click (or else your mouse or touchpad has some jitter).
Comment 2 Bug Janitor Service 2021-10-25 21:37:20 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/plasma-framework/-/merge_requests/364
Comment 3 Nate Graham 2021-10-26 16:39:45 UTC
Fixed by Noah Davis with https://invent.kde.org/frameworks/plasma-framework/-/commit/d3af00fa0be5d1d124dabc45ee1f18e32cbc26f1 in frameworks 5.88!