Bug 444226 - Wayland: Some windows don't show up on the taskbar
Summary: Wayland: Some windows don't show up on the taskbar
Status: RESOLVED DUPLICATE of bug 429168
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.23.1
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
Keywords: wayland
Depends on:
Reported: 2021-10-22 07:43 UTC by Sergey
Modified: 2022-04-22 19:30 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Note You need to log in before you can comment on or make changes to this bug.
Description Sergey 2021-10-22 07:43:22 UTC
While X11 Plasma session is terribly buggy and unusable starting from 5.23 I decided to switch to Wayland which is also not perfect but at least doesn't have graphical artifacts on the screen and doesn't crash all the Qt apps.

So with Wayland one thing annoys me a lot: Not every application appears on the task bar. I tried to add another panel and tried to play with all the checkboxes in settings but those apps just do no appear. Even so their windows are visible and usable and also available by alt+tab and via "Windows list" widget. Also with X11 Plasma session I never had this issue (even so I had others like taskbar is always empty till next restart).

So essentially only the problem seems to in some incompatibility of Wayland session and the taskbar.

Examples of applications: Qt Creator, gvim

1. Start Qt Creator

Qt Creator works properly but absent on the taskbar

All GUI apps are definitely visible on the taskbar

Linux/KDE Plasma: Gentoo
(available in About System)
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87
Qt Version: 5.15.2

Wrt my X11 problems, in my MSI GL75 9SDK laptop I have Nvidia video card and proprietary driver 495.29.05-r1. I also tried 470.74 just to check if X11 Plasma session would become stable but it didn't. It reports "qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found." for every Qt app but somehow starts plasmashell anyway even being Qt based.
I would be happy to return to X11.
Comment 1 Sergey 2021-10-22 07:45:20 UTC
And yes being a programmer I could fix it myself if one can just point me to the right direction.
Comment 2 Nate Graham 2021-10-22 16:43:36 UTC
Thanks! The Task Manager code is in https://invent.kde.org/plasma/plasma-desktop/-/tree/master/applets/taskmanager
Comment 3 kinghat 2021-10-29 15:39:47 UTC
im not sure if this is the same issue but i only sometimes get application/window icons in the task manager widget in my panel. when i do see them they end up disappearing eventually. started with plasma 5.23.
Comment 4 kinghat 2021-10-29 15:48:55 UTC
actually think its this one: https://bugs.kde.org/show_bug.cgi?id=429168, sorry.
Comment 5 Nate Graham 2022-01-12 17:06:09 UTC

*** This bug has been marked as a duplicate of bug 429168 ***
Comment 6 spamulousbastard+kde 2022-04-22 19:30:42 UTC
(In reply to Nate Graham from comment #5)
> *** This bug has been marked as a duplicate of bug 429168 ***

It might instead be Bug 444325. I'm seeing somewhat similar symptoms with gVim on Fedora 35, except it's invisible to "Window List" as well as "Task Manager", but not alt+tab.