Bug 444185 - System Settings crash
Summary: System Settings crash
Status: RESOLVED DUPLICATE of bug 429442
Alias: None
Product: systemsettings
Classification: Applications
Component: general (show other bugs)
Version: 5.23.1
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2021-10-21 10:51 UTC by nufcjd
Modified: 2021-10-21 14:25 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nufcjd 2021-10-21 10:51:38 UTC
Application: systemsettings5 (5.23.1)
 (Compiled from sources)
Qt Version: 5.15.2
Frameworks Version: 5.87.0
Operating System: Linux 5.14.14-arch1-1 x86_64
Windowing System: X11
Distribution: EndeavourOS
DrKonqi: 5.23.1 [KCrashBackend]

-- Information about the crash:
- What I was doing when the application crashed:

installing global theme. After I added password for new sddm the settings app crashed
- Unusual behavior I noticed:

crash
- Custom settings of the application:
none

The crash can be reproduced every time.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault

[KCrash Handler]
#4  0x00007f60da9e7819 in QDir::fromNativeSeparators(QString const&) () at /usr/lib/libQt5Core.so.5
#5  0x00007f60da9fb8c7 in QFileInfo::QFileInfo(QString const&) () at /usr/lib/libQt5Core.so.5
#6  0x00007f60cc287ed7 in  () at /usr/lib/qt/plugins/kcms/kcm_lookandfeel.so
#7  0x00007f60cc285a0b in  () at /usr/lib/qt/plugins/kcms/kcm_lookandfeel.so
#8  0x00007f60d9962c9e in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007f60d983e121 in  () at /usr/lib/libQt5Qml.so.5
#10 0x00007f60d983ff6b in QV4::QObjectMethod::callInternal(QV4::Value const*, QV4::Value const*, int) const () at /usr/lib/libQt5Qml.so.5
#11 0x00007f60d985d0c0 in  () at /usr/lib/libQt5Qml.so.5
#12 0x00007f60d985fdbf in  () at /usr/lib/libQt5Qml.so.5
#13 0x00007f60d97f20df in QV4::Function::call(QV4::Value const*, QV4::Value const*, int, QV4::ExecutionContext const*) () at /usr/lib/libQt5Qml.so.5
#14 0x00007f60d997df36 in QQmlJavaScriptExpression::evaluate(QV4::CallData*, bool*) () at /usr/lib/libQt5Qml.so.5
#15 0x00007f60d992e53d in QQmlBoundSignalExpression::evaluate(void**) () at /usr/lib/libQt5Qml.so.5
#16 0x00007f60d992f799 in  () at /usr/lib/libQt5Qml.so.5
#17 0x00007f60d9962755 in QQmlNotifier::emitNotify(QQmlNotifierEndpoint*, void**) () at /usr/lib/libQt5Qml.so.5
#18 0x00007f60dab0c2c8 in  () at /usr/lib/libQt5Core.so.5
#19 0x00007f60cc16a771 in  () at /usr/lib/qt/qml/org/kde/newstuff/libnewstuffqmlplugin.so
#20 0x00007f60cc172d4b in  () at /usr/lib/qt/qml/org/kde/newstuff/libnewstuffqmlplugin.so
#21 0x00007f60dab0c76b in  () at /usr/lib/libQt5Core.so.5
#22 0x00007f60cc1c51c7 in KNSCore::Engine::signalEntryEvent(KNSCore::EntryInternal const&, KNSCore::EntryInternal::EntryEvent) () at /usr/lib/libKF5NewStuffCore.so.5
#23 0x00007f60dab0c76b in  () at /usr/lib/libQt5Core.so.5
#24 0x00007f60cc1c4483 in KNSCore::Installation::signalEntryChanged(KNSCore::EntryInternal const&) () at /usr/lib/libKF5NewStuffCore.so.5
#25 0x00007f60cc1f2dd0 in  () at /usr/lib/libKF5NewStuffCore.so.5
#26 0x00007f60dab0c76b in  () at /usr/lib/libQt5Core.so.5
#27 0x00007f60dadd30dd in KJob::result(KJob*, KJob::QPrivateSignal) () at /usr/lib/libKF5CoreAddons.so.5
#28 0x00007f60dadd45cc in KJob::finishJob(bool) () at /usr/lib/libKF5CoreAddons.so.5
#29 0x00007f60dab0250f in QObject::event(QEvent*) () at /usr/lib/libQt5Core.so.5
#30 0x00007f60db6c6d62 in QApplicationPrivate::notify_helper(QObject*, QEvent*) () at /usr/lib/libQt5Widgets.so.5
#31 0x00007f60daad53ba in QCoreApplication::notifyInternal2(QObject*, QEvent*) () at /usr/lib/libQt5Core.so.5
#32 0x00007f60daad84b9 in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () at /usr/lib/libQt5Core.so.5
#33 0x00007f60dab2e9b4 in  () at /usr/lib/libQt5Core.so.5
#34 0x00007f60d868a4dc in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#35 0x00007f60d86de749 in  () at /usr/lib/libglib-2.0.so.0
#36 0x00007f60d8687bc1 in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#37 0x00007f60dab2dfe6 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#38 0x00007f60daad3d2c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#39 0x00007f60daadc294 in QCoreApplication::exec() () at /usr/lib/libQt5Core.so.5
#40 0x000055f3ab243954 in  ()
#41 0x00007f60da461b25 in __libc_start_main () at /usr/lib/libc.so.6
#42 0x000055f3ab2446be in  ()
[Inferior 1 (process 2842) detached]

Possible duplicates by query: bug 444130, bug 444074, bug 444019, bug 443857, bug 443722.

Reported using DrKonqi
Comment 1 Nate Graham 2021-10-21 14:25:23 UTC

*** This bug has been marked as a duplicate of bug 428835 ***
Comment 2 Nate Graham 2021-10-21 14:25:40 UTC

*** This bug has been marked as a duplicate of bug 429442 ***