Bug 444132 - Sometimes can't type in kickoff search box (on primary display) when mouse pointer is on secondary display
Summary: Sometimes can't type in kickoff search box (on primary display) when mouse po...
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.23.0
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2021-10-20 17:25 UTC by Washington
Modified: 2021-11-21 17:27 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Washington 2021-10-20 17:25:09 UTC
SUMMARY

Sometimes can't type in kickoff search box (on primary display) when mouse pointer is on secondary display.

STEPS TO REPRODUCE
1. Focus/Select a window on secondary display
2. Hit super "key", now kickoff is visible
3. Start typing
4. Nothing happens, kickoff search box is empty.
Comment 1 Gusted 2021-10-27 18:38:22 UTC
Hey, since a few days I also seems to be affected by this bug. The steps to reproduce are spot-on, a minor thing that noticed me that the text will be typed into the kickoff search box from the secondary display. As well that once this bug has happens, that it won't "recover" from this bug, until you reboot again.
Comment 2 Noah Davis 2021-10-27 20:37:53 UTC
Wayland or X11?
Comment 3 Gusted 2021-10-27 20:49:35 UTC
(In reply to Noah Davis from comment #2)
> Wayland or X11?

X11
Comment 4 Nico Lynzaad 2021-10-28 18:56:46 UTC
The search function seems to not be focused and isolated to the launcher in which it is present. 

Rather it is activated and focused on 1 of the multiple monitors (how this is determined I've not been able to figure out). In my case I have 3 monitors with the search being functional on monitor 2 but not on 1 & 3. 

This creates a major problem when using multiple kickoff launchers across multiple monitors (in my case 3 monitors).

This can be seen in 3 different scenarios (with all search fields cleared in between each scenario):

1.1) Open the launcher on screen 1 (via clicking on the icon or through meta key).
1.2) Starting to type a search string for example "ev" to search for evolution
1.3) Nothing happens on the open launcher on monitor 1. 
1.4) Opening the launcher on screen 2 then shows both the search string and the results.

2.1) Open the launcher on screen 1 (via clicking on the icon or through meta key).
2.2) Click inside the search bar.
2.3) Star to type a search string for example "ev" to search for evolution
2.4) The results are blank on monitor 1. 
2.5) Opening the launcher on screen 2 then shows both the search string and the results.

3.1) Open the launcher on screen 1 (via clicking on the icon or through meta key).
3.2) Star to type a search string for example "ev" to search for evolution.
3.3) nothing happens.
3.4) Click inside the search bar.
3.5) type a different search string ("abc")
3.6) search results are shown for the original search string and the new string inside the search box is ignored, i.e evolution is to top result.
3.7) Opening the launcher on screen 2 then shows both the original search string and the same results as on screen 1.
Comment 5 Daniel 2021-11-19 02:49:02 UTC
I'm seeing that I just can't type in the menu on the secondary display no matter what until I click the search box.  The primary menu works fine no matter where my mouse pointer is.

Could this be related to Bug 443131?
Comment 6 Nate Graham 2021-11-21 17:27:04 UTC
Same root cause, yeah.

*** This bug has been marked as a duplicate of bug 443131 ***