Bug 444040 - Kickoff (Application Launcher 2.0) type to search regression with multiple screens instances
Summary: Kickoff (Application Launcher 2.0) type to search regression with multiple sc...
Status: RESOLVED DUPLICATE of bug 443131
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: 5.23.0
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-19 12:44 UTC by Victor
Modified: 2021-10-19 19:19 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Victor 2021-10-19 12:44:41 UTC
SUMMARY
Kickoff (Application Launcher 2.0) type to search regression with multiple instances of Kickoff because of multi-screen usage: No character is being input.

After upgrading to KDE Neon 5.23.0, whenever opening any of the screens application launcher and start typing to search, nothing is happening, no character is appearing in the "Search..." input field at the top of the menu.

STEPS TO REPRODUCE
1. Add one or more "Default Panel" which comes with Kickoff by default as the application launcher on each screen.
2. Open any of the Kickoff instance and use it.
3. Open any other of the Kickoff instances and type directly without clicking in the "Search..." input field at the top.

OBSERVED RESULT
Nothing happens in that other Kickoff instance; no character is appearing in that Kickoff instance "Search..." input.
If you try then clicking in the "Search..." input field and type then you see the characters you are now typing but the search doesn't work.
But if you open the initial Kickoff instance then you see all the characters you typed before and that didn't appear in the second Kickoff instance.

EXPECTED RESULT
In the previous version of KDE neon 5.22.90, whatever Kickoff instance you may have opened, typing directly filled the "Search..." input field and the search was working just fine.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: KDE neon 5.23.0 (user)
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
Graphics Platform: X11
Screens: 3
Comment 1 stevenmcfeely42 2021-10-19 16:15:51 UTC
This bug is also occurring on my dual monitor system which has one Kickoff menu on each display. 

"Observed Result...

If you try then clicking in the "Search..." input field and type then you see the characters you are now typing but the search doesn't work."

I should add for clarity, that, at least for me, text in this case is not being inputted to the earliest created Kickoff menu's search field. 

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Arch Linux x86_64
Kernel: 5.14.12-arch1-1
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Graphics Platform: X11
Screens: 2
Comment 2 Claudio 2021-10-19 19:19:24 UTC

*** This bug has been marked as a duplicate of bug 443131 ***