Bug 443855 - Options to disable middle click paste, but keep middle mouse click
Summary: Options to disable middle click paste, but keep middle mouse click
Status: RESOLVED DUPLICATE of bug 441668
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_mouse (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-16 21:21 UTC by Bronson
Modified: 2022-04-07 18:35 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bronson 2021-10-16 21:21:54 UTC
SUMMARY
I have several web apps that rely on middle mouse for panning and navigation. However it always pastes my clipboard into the app. This is a real nightmare as it pastes in confidential information or whatever you have in the clipboard. Figma (https://www.figma.com/) is a prime example of this.

STEPS TO REPRODUCE
1. Middle mouse text field, notice it pastes.


OBSERVED RESULT
Paste on middle mouse.

EXPECTED RESULT
A way to not paste, just middle click.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 5.22.5
(available in About System)
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86
Qt Version: 5.12.2
Comment 1 David Edmundson 2021-10-16 22:48:58 UTC
X or wayland?
Comment 2 Bronson 2021-10-16 22:52:14 UTC
On X11.

I'll have to check wayland.
Comment 3 Bug Janitor Service 2021-10-31 04:35:08 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 4 Bug Janitor Service 2021-11-15 04:39:14 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 5 Bronson 2021-12-09 08:14:34 UTC
The same issue occurs under wayland. Middle click pastes in all applications with no option to disable it.
Comment 6 Nate Graham 2022-04-07 14:55:11 UTC

*** This bug has been marked as a duplicate of bug 441668 ***