Bug 443755 - Buttons in ExpandableListIem's expanded list can overlap with highlight depending on font size
Summary: Buttons in ExpandableListIem's expanded list can overlap with highlight depen...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-plasma
Classification: Frameworks and Libraries
Component: components (show other bugs)
Version: 5.87.0
Platform: Neon Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-15 02:48 UTC by toni_rocha
Modified: 2021-10-18 19:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.88


Attachments
Wrong panel design. (62.10 KB, image/jpeg)
2021-10-15 02:48 UTC, toni_rocha
Details
Another example. (151.44 KB, image/jpeg)
2021-10-15 03:27 UTC, toni_rocha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description toni_rocha 2021-10-15 02:48:06 UTC
Created attachment 142453 [details]
Wrong panel design.

SUMMARY
Error in design of the vault panel in "Configure vault" option when it is focused.

STEPS TO REPRODUCE
1. Open the vault panel.
2. Select and expand an existent vault.
3. Focus the "Configure vault" option. The line border is in a wrong position.

OBSERVED RESULT
When the "Configure vault" option is focused this line border is in a wrong position.

EXPECTED RESULT
A correct position of the line border when the "Configure vault" option is focused.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.23.0
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3
Comment 1 toni_rocha 2021-10-15 03:27:41 UTC
Created attachment 142456 [details]
Another example.
Comment 2 toni_rocha 2021-10-18 01:30:40 UTC
(Wrong position = overlapping label and panel.)
Comment 3 Nate Graham 2021-10-18 03:09:52 UTC
Cannot reproduce with Noto Sans 10pt or 11pt. What font size are you using? Also are you *sure* you've got Frameworks 5.87? I ask because I fixed an issue like this recently and the fix was supposed to be released in Frameworks 5.87. So it would make sense if you actually had 5.86 and not 5.87.
Comment 4 Nate Graham 2021-10-18 03:10:23 UTC
.
Comment 5 toni_rocha 2021-10-18 03:19:15 UTC
(In reply to Nate Graham from comment #3)
> Cannot reproduce with Noto Sans 10pt or 11pt. What font size are you using?
> Also are you *sure* you've got Frameworks 5.87? I ask because I fixed an
> issue like this recently and the fix was supposed to be released in
> Frameworks 5.87. So it would make sense if you actually had 5.86 and not
> 5.87.

The version of KDE Framework is 5.87.0, and the link below is a print of my fonts (I like little fonts):

https://i.ibb.co/3FZCYhr/Screenshot-20211018-001525.png
Comment 6 toni_rocha 2021-10-18 03:21:38 UTC
I now have discovered that the widget "Disk & Devices" has the same problem here. Print below, should I report a new bug?

https://i.ibb.co/dgG3yT6/overlapping.jpg
Comment 7 Nate Graham 2021-10-18 03:23:26 UTC
Can reproduce with 8pt DejaVu Sans, thanks.

I'll look into it.
Comment 8 Nate Graham 2021-10-18 03:23:47 UTC
No need to submit a new bug report; the issue in a common component used by multiple applets.
Comment 9 toni_rocha 2021-10-18 03:25:36 UTC
(In reply to Nate Graham from comment #8)
> No need to submit a new bug report; the issue in a common component used by
> multiple applets.

Ok, thanks.
Comment 10 Nate Graham 2021-10-18 19:11:20 UTC
Git commit a61587a08cb400eddd1c036ecbf21b94381883f7 by Nate Graham.
Committed on 18/10/2021 at 19:09.
Pushed by ngraham into branch 'master'.

ExpandableListItem: Finally fix expanded height calculation permanently

After many different approaches to determine the height of the expanded
view popup, the simplest and most robust is to do nothing at all and let
the implicit size bubble up, which works just fine in this case because
the items own implicit heights will automatically take into
consideration the font size, and any invisible disabled items won't be
added to the implicit height, so the final height calculation will
always be correct with any set of items and font size.
FIXED-IN: 5.88

M  +0    -3    src/declarativeimports/plasmaextracomponents/qml/ExpandableListItem.qml

https://invent.kde.org/frameworks/plasma-framework/commit/a61587a08cb400eddd1c036ecbf21b94381883f7