Bug 443712 - Bottom panel hides lower part of windows including the confirmation buttons at lower resolutions
Summary: Bottom panel hides lower part of windows including the confirmation buttons a...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Panel (show other bugs)
Version: 5.22.5
Platform: Other Linux
: NOR grave
Target Milestone: 1.0
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-14 13:58 UTC by paninomaninodesu
Modified: 2021-10-20 14:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.23.2


Attachments
example of the problem (109.70 KB, image/png)
2021-10-14 13:58 UTC, paninomaninodesu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description paninomaninodesu 2021-10-14 13:58:55 UTC
Created attachment 142429 [details]
example of the problem

SUMMARY
Interface/Windows does no fit on screen with no way to resize to make it fit

STEPS TO REPRODUCE
1. Click "Status and Notifications" arrow on system tray, click "Configure System Tray" (a windows will open maximized)
2. Select side menu "Entries", change any option/icon's "Visibility"
3. Scroll down, there's not buttons to apply and save the changes, it's hidden behind the bottom panel.

OBSERVED RESULT
I'm unable to change the visibility of the icons in the system tray

EXPECTED RESULT
That the buttons to apply the changes would be visible and clickable without any additional step to workaround the problem

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Neon
(available in About System)
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
The solution is the click on the "restore button", the one on the middle in the tittle bar to resize and decrease the size of the window and than maximize it again. This changes the shape of the window, pushing the buttons up and making it half visible, enough to click on them.
Would be better if this did not happen, but it's worse because makes you notice not a bug, but a limitation that Plasma 5 has for some time already (or ever did). You can not resize the sizes of some windows, apparently those related to configuration interfaces at will. That window to configure the system tray have that minimum size, you can't get lower than that, the layout doesn't adapt to lower sizes. Why?

I'm linking two images with examples of this.

https://i.imgur.com/Crvz6Ps.png
https://i.imgur.com/qDElQVY.png


I imagine that this problem is invisible for people using higher resolution screen. This should only be a problem on low resolutions like the one I'm using now.
I tried to change the visibility of the panel, but there's not satisfactory option. The option it's lacking is to make the windows attach to the top of the panel instead of making the panel visible or not above the windows.
Comment 1 paninomaninodesu 2021-10-14 14:03:31 UTC
Graphics running under X11 and OpenGL 2.0
Comment 2 Nate Graham 2021-10-14 23:03:47 UTC
Seems like the minimum height of this window is too tall. There isn't a generic way to fix this at the panel level; we need to fix individual windows that are too tall. I'll fix this one.
Comment 3 Bug Janitor Service 2021-10-14 23:12:59 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/599
Comment 4 paninomaninodesu 2021-10-15 03:46:43 UTC
(In reply to Nate Graham from comment #2)
> Seems like the minimum height of this window is too tall. There isn't a
> generic way to fix this at the panel level; we need to fix individual
> windows that are too tall. I'll fix this one.

I think that changing how the panel visibility behaves would solve this for all cases. Like it works on Windows, the windows try to stick immediately above the bottom panel and try to not get behind it. 

If you want to change the minimum size of these windows, in the case of the resolution 1280x768 that it's still so common, some pixels just need to be "reserved" to the bottom panel, so just subtract the standard bottom panel height from 768.
Comment 5 Nate Graham 2021-10-15 15:32:14 UTC
Sadly there isn't a generic way to fix this. If we made the window always appear above the panel, its titlebar could get cut off which would be even worse--the user would be left with no visible way to move or close the window.

Ultimately we just need to fix bugs as they come up on a case-by-case basis. In this case the fix was easy since the window was setting a minimum height that was inappropriately high.
Comment 6 Nate Graham 2021-10-19 14:15:48 UTC
Git commit 4e13d08c54d79bb8983f47ff77065d4e683c8c05 by Nate Graham.
Committed on 19/10/2021 at 14:15.
Pushed by ngraham into branch 'master'.

Make Applet config window a tiny bit smaller and reduce minimum size

There's no point in setting an implicit size that's the same as the
minimum size so let's reduce the minimum size to be smaller than the
minimum size so that the window can be made smaller by the user, or by
the system in case a small screen is being used. Also reduce the default
height a tiny bit.
FIXED-IN: 5.24

M  +3    -3    desktoppackage/contents/configuration/AppletConfiguration.qml

https://invent.kde.org/plasma/plasma-desktop/commit/4e13d08c54d79bb8983f47ff77065d4e683c8c05
Comment 7 Nate Graham 2021-10-20 14:54:51 UTC
Git commit 753f82d7fa60ab53bdf17ba8a2a178f04acabc19 by Nate Graham.
Committed on 20/10/2021 at 14:54.
Pushed by ngraham into branch 'Plasma/5.23'.

Make Applet config window a tiny bit smaller and reduce minimum size

There's no point in setting an implicit size that's the same as the
minimum size so let's reduce the minimum size to be smaller than the
minimum size so that the window can be made smaller by the user, or by
the system in case a small screen is being used. Also reduce the default
height a tiny bit.
FIXED-IN: 5.24
(cherry picked from commit 4e13d08c54d79bb8983f47ff77065d4e683c8c05)

M  +3    -3    desktoppackage/contents/configuration/AppletConfiguration.qml

https://invent.kde.org/plasma/plasma-desktop/commit/753f82d7fa60ab53bdf17ba8a2a178f04acabc19