Bug 443588 - Provide more guidance to new users for initial setup
Summary: Provide more guidance to new users for initial setup
Status: RESOLVED DUPLICATE of bug 425202
Alias: None
Product: kdenetwork-filesharing
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Fedora RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
Keywords: usability
Depends on:
Reported: 2021-10-11 10:41 UTC by Daniel
Modified: 2022-08-02 22:18 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2021-10-11 10:41:40 UTC
I just installed kdenetwork-filesharingon Fedora 34, right-clicked on a folder in Dolphin, and clicked on the new Share tab. There I get an error message saying:

“You appear to not have sufficient permissions to manage Samba user shares.”

The first thing I tried troubleshooting is whether the smb.service was running. It wasn’t. There should probably be a specific error message for that, as it should be easy to detect and provide guidance. Maybe even a button to elevate permissions and start and enable the service.

I still get the same error in Dolphin, though. I guess it needs me to do some more setup, but I don’t know what it expects me to do. As a user faced with this message, there’s no clear path forward to get things working.

There should be more details and a help link on this screen.

Some searching reveals there’s a related YaST2 settings panel in OpenSUSE, but other distro’s don’t appear to have anything similar.
Comment 1 Harald Sitter 2021-10-11 12:08:07 UTC
What does this command have to say:

testparm --debuglevel=0 --suppress-prompt --verbose --parameter-name 'usershare path' 2> /dev/nul
Comment 2 Daniel 2021-10-11 13:43:27 UTC
Hi Harald,

It returns `/var/lib/samba/usershares`. That file doesn’t exist, though. No system packages provide it either. There are ten other files in that directory.
Comment 3 Daniel 2021-10-11 13:57:24 UTC
This blog post documents the changes I need to make to my system:


Enabling the samba service and configuring samba usershare seems like it should be the same across distros, and something kdenetwork-filesharing could detect and advise on. The selinux policy change is probably Fedora-specific, but checking read-permissions and then suggesting to check directory permissions and security policies can be a cross-distro check.
Comment 4 Nate Graham 2021-10-11 14:58:30 UTC
Thanks for the info!
Comment 5 Harald Sitter 2021-10-12 12:23:09 UTC
Seems to me all of this is an issue in Fedora. selinux is purely their choice. Shipping samba with a usershares folder configured that does not actually exist on disk is too. Not enabling services is too.

The way I see it installing kdenetwork-fielsharing, the rpm, should either ensure the foundational aspects of samba are in order, or the package as whole should not exist. Most other distros manage to create a directory and setup group ownership correctly, I'm sure fedora can manage too.
Comment 6 Nate Graham 2021-10-12 20:22:04 UTC
> Shipping samba with a usershares folder configured that does not actually exist on disk is too
That seems like a fixable bug that we can report to them.

> Not enabling services is too
This seems more reasonable for the distro to not do; a lot of distros are wary about the security implications of having a samba server running even if the user hasn't explicitly created any shares. I think it's reasonable to have Samba installed but to have the service off until the need arises--i.e. by the user creating a share here. Which means this thing should be able to turn the service on when needed.
Comment 7 Nate Graham 2022-08-02 22:18:10 UTC
Bug 425202is being fixed, which should effectively fix this too.

*** This bug has been marked as a duplicate of bug 425202 ***