Bug 443474 - CTL-4100WL/Wacom Intuos BT S (bluetooth) - wrong key mappings
Summary: CTL-4100WL/Wacom Intuos BT S (bluetooth) - wrong key mappings
Status: REPORTED
Alias: None
Product: wacomtablet
Classification: Unclassified
Component: general (show other bugs)
Version: 3.2.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Valerii Malov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-08 11:49 UTC by lylewang.au
Modified: 2022-01-22 14:15 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lylewang.au 2021-10-08 11:49:22 UTC
SUMMARY

Hardware model: Wacom  CTL-4100WL/Wacom Intuos BT S (bluetooth)

I have been using my Wacom tablet without any issue since I reported the bug [1] and got fixed a few years ago. Recently I haven't used it for a few months then seems there was an update in Sep 2021 and today I re-connected my tablet found the key mappings were messed and it seems the keys on stylus pen as well as the express keys on the tab don't work as configured in the kcm_wacomtablet GUI .

Tried to remove ~/.config/tabletdblocalrc file then disconnect/reconnect the tablet, but it didn't re-create the file, so this file is not used anymore ?

Also tried to downgrade kcm_wacomtablet and libwacom packages to earlier version and rebooted, didn't help.

~/.config/tabletprofilesrc file attach as in [2]

Many Thanks !


STEPS TO REPRODUCE
1. Open kcm_wacomtablet GUI to define stylus keys and express keys
2. Use stylus and express keys, but they don't behave as expected
3. For example, when I configure the Button-2 on stylus to be "mouse left key" , however when I press it, it seems doing copy/paste (ctrl+V)


OBSERVED RESULT
The buttons on Stylus and express keys don't respect the configuration in kcm_wacomtablet GUI

EXPECTED RESULT
The buttons on Stylus and express keys follow the configuration in kcm_wacomtablet GUI to behave.


SOFTWARE/OS VERSIONS

Operating System: Fedora 34
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.14.9-200.fc34.x86_64 (64-bit)
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-10850H CPU @ 2.70GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Mesa Intel® UHD Graphics



Name         : libwacom
Version      : 1.12
Release      : 1.fc34
Architecture : x86_64
Size         : 109 k
Source       : libwacom-1.12-1.fc34.src.rpm
Repository   : @System
From repo    : updates
Summary      : Tablet Information Client Library
URL          : https://github.com/linuxwacom/libwacom


Name         : kcm_wacomtablet
Version      : 3.2.0
Release      : 5.fc34
Architecture : x86_64
Size         : 2.1 M
Source       : kcm_wacomtablet-3.2.0-5.fc34.src.rpm
Repository   : @System
From repo    : updates
Summary      : KDE Control module for Wacom Graphictablets
URL          : https://invent.kde.org/system/wacomtablet




ADDITIONAL INFORMATION


[1] - https://bugs.kde.org/show_bug.cgi?id=397775


[2]

$ cat ~/.config/tabletprofilesrc 
[056A:0377]
CurrentProfileEntry=-1
ProfileRotationList=

[056A:0377][Default][eraser]
Button1=0
Button2=1
Button3=3
Mode=relative
PressureCurve=0 0 100 100
RawSample=5
Rotate=auto
ScreenSpace=desktop
Suppress=2
TabletPcButton=off
Threshold=502

[056A:0377][Default][pad]
Button1=key ctrl c
Button2=key ctrl v
Button3=key pgup
Button4=key pgdn

[056A:0377][Default][stylus]
Area=0 0 0 0
Button1=0
Button2=1
Button3=3
Mode=relative
PressureCurve=0 0 100 100
RawSample=5
Rotate=auto
ScreenSpace=desktop
Suppress=2
TabletPcButton=off
Threshold=754
Comment 1 lylewang.au 2021-10-10 23:26:57 UTC
downgraded libwacom package from 1.12-1.fc34 to 1.9-2.fc34 --> didn't help

then downgraded kcm_wacomtablet package from 3.2.0-5.fc34 to 3.2.0-3.fc34 --> the tablet now behaves as before (expectred :)
Comment 2 Torkin 2022-01-22 14:15:11 UTC
I'm experiencing same issue with a Wacom Bamboo Fun CTH-461. Issue came out after upgrading Fedora Linux from 34 to 35, and the first version of kcm_wacomtablet available in Fedora Linux 35 is 3.2.0-5, so I cannot try to downgrade it.