Bug 443425 - When switching to another virtual desktop, the media controller is still visible in the tooltip but cannot be interacted with
Summary: When switching to another virtual desktop, the media controller is still visi...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: master
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-10-07 07:46 UTC by Fushan Wen
Modified: 2021-10-18 16:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.23.1


Attachments
The media controller (37.68 KB, image/png)
2021-10-07 07:46 UTC, Fushan Wen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Fushan Wen 2021-10-07 07:46:31 UTC
Created attachment 142232 [details]
The media controller

SUMMARY
If the media player is pinned to Task Manager, after opening the media player and switching to another virtual desktop, the media controller will be still visible in the tooltip.

STEPS TO REPRODUCE
1. Pin Audacious to Task Manager
2. Open Audacious
3. Switch to another virtual desktop

OBSERVED RESULT
the media controller is visible in the tooltip.

EXPECTED RESULT
the media controller shoud not be visible in the tooltip.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20211005
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.6-2-default (64-bit)
Graphics Platform: X11
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 15.0 GiB of RAM
Graphics Processor: AMD RENOIR

Information for package plasma5-desktop:
----------------------------------------
Repository     : unstable-kde-frameworks
Name           : plasma5-desktop
Version        : 5.23.80git.20211006T130151~fd49cc02d-ku.14.1
Arch           : x86_64
Vendor         : obs://build.opensuse.org/KDE:Unstable
Installed Size : 18.1 MiB
Installed      : Yes
Status         : up-to-date
Source package : plasma5-desktop-5.23.80git.20211006T130151~fd49cc02d-ku.14.1.src
Summary        : The KDE Plasma Workspace Components
Description    : 
    This package contains the basic packages for a Plasma workspace.
Comment 1 Bug Janitor Service 2021-10-07 07:50:57 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/594
Comment 2 Nate Graham 2021-10-07 16:05:51 UTC
Per discussion in https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/594, this seems to be intentional, so that you can control media playing in a window that isn't visible. Are the buttons interactive? Do they work?
Comment 3 Fushan Wen 2021-10-07 16:07:58 UTC
No, the tooltip is not interactive, therefore those buttons are not clickable.

(interactive property is also related to isWin)
Comment 4 Fushan Wen 2021-10-07 16:10:11 UTC
(In reply to qydwhotmail from comment #3)
> No, the tooltip is not interactive, therefore those buttons are not
> clickable.
> 
> (interactive property is also related to isWin)

interactive: model.IsWindow === true

https://invent.kde.org/plasma/plasma-desktop/-/blob/08465d3000e7b1c7ae154e6afb4a98aacc9173b7/applets/taskmanager/package/contents/ui/Task.qml#L332
Comment 5 Nate Graham 2021-10-07 16:11:13 UTC
OK, that's the problem that needs solving, then. :)
Comment 6 Nate Graham 2021-10-18 16:16:44 UTC
Git commit d3bb796a1973624aa7a0381549166a920eb96eab by Nate Graham, on behalf of Fushan Wen.
Committed on 18/10/2021 at 16:16.
Pushed by ngraham into branch 'master'.

Make tooltip interactive when there is a player but no window is present

If a media player is pinned to Task Manager, after opening the media
player and switching to another virtual desktop, the media controller
will be still visible in the tooltip but cannot be interacted with.

Move hasPlayer property to ToolTipDelegate.qml, and add
mainItem.hasPlayer to interactive property of ToolTipArea to fix the bug.

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +4    -0    applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +0    -3    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://invent.kde.org/plasma/plasma-desktop/commit/d3bb796a1973624aa7a0381549166a920eb96eab
Comment 7 Nate Graham 2021-10-18 16:18:26 UTC
Git commit 796eb9e09b25cac45d50a3a38a6cbbc2e756d64c by Nate Graham, on behalf of Fushan Wen.
Committed on 18/10/2021 at 16:18.
Pushed by ngraham into branch 'Plasma/5.23'.

Make tooltip interactive when there is a player but no window is present

If a media player is pinned to Task Manager, after opening the media
player and switching to another virtual desktop, the media controller
will be still visible in the tooltip but cannot be interacted with.

Move hasPlayer property to ToolTipDelegate.qml, and add
mainItem.hasPlayer to interactive property of ToolTipArea to fix the bug.


(cherry picked from commit d3bb796a1973624aa7a0381549166a920eb96eab)

M  +1    -1    applets/taskmanager/package/contents/ui/Task.qml
M  +4    -0    applets/taskmanager/package/contents/ui/ToolTipDelegate.qml
M  +0    -3    applets/taskmanager/package/contents/ui/ToolTipInstance.qml

https://invent.kde.org/plasma/plasma-desktop/commit/796eb9e09b25cac45d50a3a38a6cbbc2e756d64c