Bug 443233 - GHNS dialog being modal can block all of Plasmashell
Summary: GHNS dialog being modal can block all of Plasmashell
Status: RESOLVED FIXED
Alias: None
Product: frameworks-knewstuff
Classification: Unclassified
Component: general (show other bugs)
Version: 5.86.0
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Dan Leinir Turthra Jensen
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2021-10-02 20:21 UTC by Gabriel
Modified: 2022-03-15 19:14 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.93


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel 2021-10-02 20:21:44 UTC
SUMMARY
Opening the wallpaper GHNS window locks everything on the desktop until it's closed again

STEPS TO REPRODUCE
1. Open "Configure Desktop and Wallpaper..."
2. Click "Get New Wallpapers..."
3. Try to do anything on the desktop, e.g. open context menu, desktop icons, etc.

OBSERVED RESULT
You are unable to do anything with the desktop until GHNS is closed again

EXPECTED RESULT
You can still interact with the desktop

SOFTWARE: 
OS: Neon Testing Edition
KDE Plasma Version: 5.22.90
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.3

ADDITIONAL INFORMATION
It affects the most when it is open on another virtual desktop, since you will not find the blocking window in the taskbar. The same happens with the wallpaper plugins GHNS window.
Comment 1 Nate Graham 2021-10-04 22:36:30 UTC
This happens because it's marked as a modal dialog, and modal dialogs block their parent app until closed. When the parent app is Plasma, Plasma gets blocked while it's open.

Options:
- Make it not be a modal dialog
- Make the modality of the dialog configurable and have Plasma open it in a non-modal way
Comment 2 Gabriel 2022-03-15 19:11:32 UTC
This bug appears to be fixed now (Plasma 5.24.3, Frameworks 5.91). Since GHNS won't even be a dialog, but a window, from Frameworks 5.93 and onward, I feel confident that this bug is past us for good – even if I can't pin-point exactly when it got fixed. Thanks devs!
Comment 3 Nate Graham 2022-03-15 19:14:37 UTC
You are correct about all of that! The exact commit was https://invent.kde.org/frameworks/knewstuff/-/commit/ea19fa6e824650f3257e8047d6f90e01899b2e03, made by Alexander Lohnau.