Bug 443132 - Status bar goes missing while loading a folder
Summary: Status bar goes missing while loading a folder
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: bars: status (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-29 19:39 UTC by Kai Uwe Broulik
Modified: 2021-11-29 22:32 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.12


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Uwe Broulik 2021-09-29 19:39:36 UTC
SUMMARY
When a folder is loading, the status bar goes missing and so there is no way to stop the load anymore.


STEPS TO REPRODUCE
1. Navigate to a slow remote location in Dolphin

OBSERVED RESULT
Main view shows "Loading..." but the status bar disappears completely while loading

EXPECTED RESULT
The status bar stays there 


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: git master as of 2021-09-27
Comment 1 Nate Graham 2021-09-30 15:35:40 UTC
Huh I thought this got fixed. I can't reproduce it anymore with my current git master.
Comment 2 Kai Uwe Broulik 2021-11-28 20:39:01 UTC
Still happens
Comment 3 Bug Janitor Service 2021-11-28 20:46:41 UTC
A possibly relevant merge request was started @ https://invent.kde.org/system/dolphin/-/merge_requests/294
Comment 4 Kai Uwe Broulik 2021-11-29 12:31:13 UTC
Git commit ec8f757f9c7b5eafcacbd9671df283d3f20f8a19 by Kai Uwe Broulik.
Committed on 29/11/2021 at 10:34.
Pushed by broulik into branch 'release/21.12'.

[Status Bar] Don't mess with status bar visibility in extensions

"Extensions" is additions to the status bar like free space bar
and zoom slider which should hide while loading.

The status bar itself should only show/hide based on the global setting.

M  +3    -3    src/statusbar/dolphinstatusbar.cpp

https://invent.kde.org/system/dolphin/commit/ec8f757f9c7b5eafcacbd9671df283d3f20f8a19