Bug 442967 - Cannot share file between phone And computer
Summary: Cannot share file between phone And computer
Status: RESOLVED FIXED
Alias: None
Product: kdeconnect
Classification: Unclassified
Component: android-application (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Albert Vaca
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-26 05:47 UTC by zyf0330
Modified: 2022-03-25 02:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description zyf0330 2021-09-26 05:47:51 UTC
SUMMARY

Share files From phone to computer or from computer to phone doesn't work

STEPS TO REPRODUCE
1. Use Send files to select file at phone
2. 
3. 

OBSERVED RESULT
Phone shows notification `Failed sending file to computer`, and computer shows notification `Receiving file from Phone` with pregress and doesn't disappear.

EXPECTED RESULT
Share successfully

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: Ubuntu 21.04
(available in About System)
KDE Plasma Version: 5.21.5
KDE Frameworks Version:  5.81.0-0ubuntu1~ubuntu21.04~ppa2
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Share from computer to phone doesn't work too, and there is no alert.

I don't find infomation in adb logcat.
Comment 1 lpcornel 2021-09-27 20:42:11 UTC
Confirmed. Flagged out of date at https://archlinux.org/packages/extra/x86_64/kdeconnect/

Upgrade of openssh (8.7p1-2 -> 8.8p1-1) causes kdeconnect to fail connect.
Comment 2 zyf0330 2021-09-28 01:41:52 UTC
(In reply to lpcornel from comment #1)
> Confirmed. Flagged out of date at
> https://archlinux.org/packages/extra/x86_64/kdeconnect/
> 
> Upgrade of openssh (8.7p1-2 -> 8.8p1-1) causes kdeconnect to fail connect.

But why kdeconnect on Ubuntu is still 20.12.3
Comment 3 MikeC 2021-09-28 07:13:18 UTC
This discussion on the Arch Linux forum is pertinent to this bug: https://bbs.archlinux.org/viewtopic.php?pid=1995116
Comment 4 lpcornel 2021-09-29 19:33:19 UTC
(In reply to zyf0330 from comment #2)
> (In reply to lpcornel from comment #1)
> > Confirmed. Flagged out of date at
> > https://archlinux.org/packages/extra/x86_64/kdeconnect/
> > 
> > Upgrade of openssh (8.7p1-2 -> 8.8p1-1) causes kdeconnect to fail connect.
> 
> But why kdeconnect on Ubuntu is still 20.12.3

The version referenced (8.8p1-1) is for openssh (in Arch), not kdeconnect. kdeconnect has not been revised to be compatible with the new version of openssh. I don't know what version of openssh applies to Ubuntu.
Comment 5 zyf0330 2021-09-30 01:51:57 UTC
(In reply to lpcornel from comment #4)

> The version referenced (8.8p1-1) is for openssh (in Arch), not kdeconnect.
> kdeconnect has not been revised to be compatible with the new version of
> openssh. I don't know what version of openssh applies to Ubuntu.

Sorry, I misunderstand. I use Ubuntu 21.04 and my openssl version is 8.4p1-5
Comment 6 MikeC 2021-09-30 09:03:01 UTC
The original report concerns kdeconnect not transferring files to an android phone in Ubuntu - which does not have the latest version of openssl, but the later report refers to a working system in Arch Linux where kdeconnect worked fine until the new version of openssl broke kdeconnect.  Perhaps that should be a new separate bug report where kdeconnect can be fixed to work with the new openssl, or possibly sshfs which depends on openssl. Either way it was the change in openssl to version 8.8p1-1 that broke functionality of kdeconnect.
Comment 7 MikeC 2021-09-30 09:18:44 UTC
I have entered a new report at https://bugs.kde.org/show_bug.cgi?id=443155
Comment 8 Alban BROWAEYS 2022-03-24 21:51:43 UTC
@zyf0330 your issue is most likely with android permission for storage. Note that on Android, in kdeconnect you have to click on the three dots menu on the top right, then select  "Plugins Settings", then in "Share and Receive" click on "Target Folder" to select a folder. That open the android file selector (left top hamburger menu to change section in the file selector, ie internal storage, recent files, etc) in which you go  to your folder in the storage and click at the bottom of the page on "Authorize access to xxx". This is required even to send files from a folder. You have to authorize the application to send files from a folder on android 11.
This way I am able to send files from the Debian computer to the Android tablet and from tablet to computer.
ssh is 1:8.4p1-5 (Debian stable). Currently I have issues with my computer mount phone folder option (ie "Expose filesystems" in "Plugins Settings").

Telling your android version might help narrow the issue in case it is another one.

Also, look at your firewall, https://fitzcarraldoblog.wordpress.com/2014/02/10/kde-connect-link-your-android-device-to-your-kde-desktop/ tells the rules for ufw.
Comment 9 zyf0330 2022-03-25 02:12:47 UTC
At now, I can send files from android phone to Ubuntu successfully. And I don't need to do filesystem expose.
I think Filesystem expose is needed for browser files in the phone from computer. And I don't know why I cannot set Download folder as storage location, just folders inside Download.
Comment 10 Alban BROWAEYS 2022-03-25 02:21:29 UTC
Sorry I am lost. Do you mean you tried to set download folder as and authorize it i. "Share and receive".
I only talked about "Filesystem Expose" because it is the only area where I jave issue with kdeconnect (and only on Android 11, 10 is fine).
To send from or to the phone this is not related. Only authorize in "Share and receive" does.
Do you mean you the authorize access button at the bottom is greyed out when you select the download folder in "Share and receive" folder location ?
Comment 11 zyf0330 2022-03-25 02:22:25 UTC
(In reply to Alban BROWAEYS from comment #10)
> Sorry I am lost. Do you mean you tried to set download folder as and
> authorize it i. "Share and receive".
> I only talked about "Filesystem Expose" because it is the only area where I
> jave issue with kdeconnect (and only on Android 11, 10 is fine).
> To send from or to the phone this is not related. Only authorize in "Share
> and receive" does.
> Do you mean you the authorize access button at the bottom is greyed out when
> you select the download folder in "Share and receive" folder location ?

Yes
Comment 12 zyf0330 2022-03-25 02:24:06 UTC
(In reply to Alban BROWAEYS from comment #10)
> Sorry I am lost. Do you mean you tried to set download folder as and
> authorize it i. "Share and receive".
> I only talked about "Filesystem Expose" because it is the only area where I
> jave issue with kdeconnect (and only on Android 11, 10 is fine).
> To send from or to the phone this is not related. Only authorize in "Share
> and receive" does.
> Do you mean you the authorize access button at the bottom is greyed out when
> you select the download folder in "Share and receive" folder location ?

Sorry. I read it wrong.
I mean Download is grayed out in Filesystem expose.
Comment 13 zyf0330 2022-03-25 02:25:23 UTC
Anyway, the original isue is resolved.