Bug 442917 - Power profiles slider doesn't show up in Battery and Brightness applet
Summary: Power profiles slider doesn't show up in Battery and Brightness applet
Status: RESOLVED NOT A BUG
Alias: None
Product: plasmashell
Classification: Plasma
Component: Battery Monitor (show other bugs)
Version: 5.22.90
Platform: Archlinux Linux
: NOR normal
Target Milestone: 1.0
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-25 01:07 UTC by Samuel Reddy
Modified: 2022-02-11 19:38 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Battery and Brightness applet (778.75 KB, image/png)
2021-09-25 01:07 UTC, Samuel Reddy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Samuel Reddy 2021-09-25 01:07:55 UTC
Created attachment 141889 [details]
Battery and Brightness applet

SUMMARY:
Plasmashell doesn't show the power profiles slider in the Battery and Brightness applet, even though I can use the powerprofilesctl command to set the profile, but it only has power-saver and balanced.

STEPS TO REPRODUCE:
1. Launch Plasma(Wayland or X11)
2. Click on the battery icon in the tray
3. No power profiles slider shown

OBSERVED RESULT:
No power profiles slider is shown in the Battery and Brightness applet.

EXPECTED RESULT:
Battery and Brightness applet should show the power profiles slider and be able to set it.

SOFTWARE/OS VERSIONS:
Operating System: Arch Linux
KDE Plasma Version: 5.22.90
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.6-zen1-1-zen (64-bit)
Graphics Platform: Wayland
Processors: 8 × AMD Ryzen 5 3450U with Radeon Vega Mobile Gfx
Memory: 5.7 GiB of RAM
Graphics Processor: AMD Radeon™ Vega 8 Graphics

ADDITIONAL INFORMATION:
I installed power-profiles-daemon and enabled the systemd service power-profiles-daemon.service
Comment 1 Antonio Rojas 2021-09-25 07:58:49 UTC
Have you restarted your session after enabling the service?
Comment 2 Samuel Reddy 2021-09-25 10:25:45 UTC
(In reply to Antonio Rojas from comment #1)
> Have you restarted your session after enabling the service?

Yes I have
Comment 3 Nate Graham 2021-09-27 21:06:33 UTC
Work for me on Fedora 34 FWIW, so it's not a universal issue. Since the CLI tool works for you, it seems like you have a supported kernel and hardware.
Comment 4 Samuel Reddy 2021-09-28 04:07:46 UTC
(In reply to Nate Graham from comment #3)
> Work for me on Fedora 34 FWIW, so it's not a universal issue. Since the CLI
> tool works for you, it seems like you have a supported kernel and hardware.

I think it is because the power profiles slider in the battery & brightness applet only works with hardware that supports the performance profile in addition to the other two profiles, so if you are on hardware that only supports power-saver and balanced, the slider won't show up.
Comment 5 David Redondo 2021-09-28 06:54:58 UTC
The power profiles slider does not appear when you are on hardware that's not supported by the daemon. powerprofilesctl should print 'Driver: placeholder' and changing the profile will in fact have not any effect, that's why it's hidden in this case
Comment 6 Nate Graham 2021-09-28 15:32:19 UTC
OK, so it's fully supported for me and I see this:


$ powerprofilesctl
  performance:
    Driver:     platform_profile
    Inhibited:  no

* balanced:
    Driver:     platform_profile

  power-saver:
    Driver:     platform_profile


What about you, Samuel?
Comment 7 Samuel Reddy 2021-09-28 21:59:12 UTC
(In reply to Nate Graham from comment #6)
> OK, so it's fully supported for me and I see this:
> 
> 
> $ powerprofilesctl
>   performance:
>     Driver:     platform_profile
>     Inhibited:  no
> 
> * balanced:
>     Driver:     platform_profile
> 
>   power-saver:
>     Driver:     platform_profile
> 
> 
> What about you, Samuel?

I'm pretty sure it is placeholder because it has only power-saver and balanced, but it is weird that other desktop environments like GNOME still show it even if it is placeholder.
Comment 8 Samuel Reddy 2021-09-29 01:50:29 UTC
  balanced:
    Driver:     placeholder

* power-saver:
    Driver:     placeholder

Yep, it is placeholder, probably because power-profiles-daemon only supports intel cpus and not amd.
Comment 9 Bharadwaj Raju 2021-09-29 04:43:13 UTC
(In reply to Samuel Reddy from comment #7)
> I'm pretty sure it is placeholder because it has only power-saver and
> balanced, but it is weird that other desktop environments like GNOME still
> show it even if it is placeholder.

You should probably file a report with GNOME so they too don't show the slider for placeholder drivers.