Bug 442733 - The task manager and cursor animation for starting applications in wayland only works if no other windows are already open.
Summary: The task manager and cursor animation for starting applications in wayland on...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.23.3
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-09-20 11:40 UTC by carlo
Modified: 2022-02-06 01:54 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description carlo 2021-09-20 11:40:28 UTC
SUMMARY The animation in the task manager and cursor when starting applications in wayland only works if there are no other applications open. 


STEPS TO REPRODUCE
1. open Firefox
2. open Dolphin
3. 

OBSERVED RESULT
while opening FF the animation works, when I open Dolphin it doesn't work, this regardless of the specific applications. 

EXPECTED RESULT
Animation should always work. 

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: 
openSUSE Leap 15.3 (repository KDE-QT)
KDE Plasma Version: 5.22.90
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
Comment 1 Nate Graham 2021-09-21 18:33:44 UTC
That's weird, cannot reproduce. This is on Wayland, right?
Comment 2 carlo 2021-09-21 20:34:32 UTC
(In reply to Nate Graham from comment #1)
> That's weird, cannot reproduce. This is on Wayland, right?

Yes wayland, I also tried to install Plasma 5.22.90 on Tumbleweed, to understand if it was a Leap problem, but also in Tumbleweed same behavior.
Basically the animation only works if there is nothing open in that virtual desktop. A greeting.
Comment 3 Nate Graham 2021-09-22 12:25:19 UTC
Aha, virtual desktops. Does it work as expected if you have only one virtual desktop?
Comment 4 carlo 2021-09-23 19:30:46 UTC
(In reply to Nate Graham from comment #3)
> Aha, virtual desktops. Does it work as expected if you have only one virtual
> desktop?

No, it doesn't seem related, even with just one desktop the problem remains.
However I tried to reset all the settings and I noticed that now it works every now and then, but random.
Comment 5 carlo 2021-10-18 18:00:27 UTC
However, the problem persists, I have seen that some on Reddit have already reported it.
Some claim they have this problem on Xorg, but I can't confirm it.
https://www.reddit.com/r/openSUSE/comments/qap3tc/523_hits_tumbleweed/
Comment 6 Oliver Williamson 2021-10-18 18:06:51 UTC
I was the OP of that comment. Just for the record: the bug happens and is reproducible on my system.
Comment 7 carlo 2021-11-15 22:50:13 UTC
Since the bug is still present on 5.23.3 I changed the version as 5.22.90 was a beta version.
I hope it goes well.
Comment 8 Nate Graham 2022-01-12 17:12:00 UTC
Still cannot reproduce in current git master (which will soon be Plasma 5.24).
Comment 9 carlo 2022-02-05 19:08:08 UTC
(In reply to Nate Graham from comment #8)
> Still cannot reproduce in current git master (which will soon be Plasma
> 5.24).

I am testing Plasma 5.24 (5.23.90) beta in Tumbleweed and I no longer have this problem.
Comment 10 Nate Graham 2022-02-06 01:54:31 UTC
Oh good!