Bug 442688 - [Wayland] Apps are moved to another virtual desktop after click on "Minimize all windows" widget
Summary: [Wayland] Apps are moved to another virtual desktop after click on "Minimize ...
Status: RESOLVED FIXED
Alias: None
Product: kwin
Classification: Plasma
Component: wayland-generic (show other bugs)
Version: git-master
Platform: Neon Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-19 11:59 UTC by Patrick Silva
Modified: 2022-01-13 21:20 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Silva 2021-09-19 11:59:35 UTC
SUMMARY
Reproducible on both Arch Linux (Plasma 5.23 beta) and neon unstable.

STEPS TO REPRODUCE
1. add "Minimize all windows" widget to Plasma panel
2. configure virtual desktops in Virtual Desktops KCM (I use 2 rows, 4 virtual desktops)
3. open some apps
4. switch to another virtual desktop
5. click on "Minimize all windows" widget

OBSERVED RESULT
apps open in the step 3 now are also present in the virtual desktop activated
in the step 4

EXPECTED RESULT
observed result should not occur

SOFTWARE/OS VERSIONS
Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 1 luminoso 2021-10-25 08:31:03 UTC
I confirm this behavior in Fedora Linux 34.

Software versions are a little different

SOFTWARE/OS VERSIONS
Operating System: Fedora Linux 34
KDE Plasma Version: 5.23.1
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2-22.fc34
Graphics Platform: Wayland (amdgpu)
Comment 2 luminoso 2021-11-10 09:24:27 UTC
Still present at 5.23.3.

I had hopes it was related with https://invent.kde.org/plasma/kwin/-/merge_requests/1603 but no luck
Comment 3 Patrick Silva 2022-01-13 21:20:31 UTC
I'm unable to reproduce on Plasma 5.24 beta.

Operating System: Arch Linux
KDE Plasma Version: 5.23.90
KDE Frameworks Version: 5.90.0
Qt Version: 5.15.2
Graphics Platform: Wayland