Bug 442668 - Bookmarks are not shown in menu after document tab is dragged or after switching between documents
Summary: Bookmarks are not shown in menu after document tab is dragged or after switch...
Status: RESOLVED FIXED
Alias: None
Product: okular
Classification: Applications
Component: general (show other bugs)
Version: 20.12.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Okular developers
URL:
Keywords:
: 447698 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-18 18:47 UTC by Dzmitry Krakadzeyau
Modified: 2021-12-30 20:17 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.08.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dzmitry Krakadzeyau 2021-09-18 18:47:45 UTC
SUMMARY

Bookmarks are not shown in the Bookmarks menu after a document tab is dragged and dropped.


STEPS TO REPRODUCE

1. Open at least one document.
2. Open a document with bookmarks (and they are visible the Bookmarks menu).
3. Drag and drop its tab to the left to change its position in the tabs bar.
4. Check the Bookmarks menu.


OBSERVED RESULT

The bookmarks are not shown in the menu anymore.


EXPECTED RESULT

The bookmarks are in place.


SOFTWARE/OS VERSIONS

Operating System: Kubuntu 21.04
KDE Plasma Version: 5.21.4
KDE Frameworks Version: 5.80.0
Qt Version: 5.15.2
Kernel Version: 5.11.0-34-generic
OS Type: 64-bit
Graphics Platform: X11
Processors: 20 × Intel® Core™ i9-10850K CPU @ 3.60GHz
Memory: 62.7 GiB of RAM
Graphics Processor: GeForce GTX 1050 Ti/PCIe/SSE2


ADDITIONAL INFORMATION

I only checked the behavior for a DjVu document.
Comment 1 Dzmitry Krakadzeyau 2021-09-18 19:31:02 UTC
UPDATE:

It seems that the bookmarks are hidden even after a simple switching to other tab and back.
Comment 2 Bug Janitor Service 2021-10-12 21:23:08 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/okular/-/merge_requests/495
Comment 3 Albert Astals Cid 2021-10-14 20:35:31 UTC
Git commit 9e2d256a6f214f7230f8575f8a61570592d35428 by Albert Astals Cid.
Committed on 12/10/2021 at 21:21.
Pushed by aacid into branch 'release/21.08'.

Fix bookmark menu actions missing after switching tabs

M  +1    -0    part/part.cpp

https://invent.kde.org/graphics/okular/commit/9e2d256a6f214f7230f8575f8a61570592d35428
Comment 4 Albert Astals Cid 2021-12-30 20:17:18 UTC
*** Bug 447698 has been marked as a duplicate of this bug. ***