Bug 442587 - [Wayland] Launch feedback on Task Manager launcher does not activate when launching that app from Kickoff
Summary: [Wayland] Launch feedback on Task Manager launcher does not activate when lau...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Task Manager and Icons-Only Task Manager (show other bugs)
Version: 5.24.0
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords: wayland
Depends on:
Blocks:
 
Reported: 2021-09-17 10:27 UTC by Derek Christ
Modified: 2022-05-13 15:00 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.25


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Derek Christ 2021-09-17 10:27:28 UTC
SUMMARY
Since Bug 402903 is now resolved, we finally have launch feedback when opening an application on Wayland.
However, the launch feedback does not work when an app is launched using the kickoff launcher.
Launching from the desktop or from any other application (KRunner) works fine. 

STEPS TO REPRODUCE
1. Open Kickoff launcher
2. Launch an application
3. No launch feedback

OBSERVED RESULT
No launch feedback

EXPECTED RESULT
Launch feedback

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20210914
KDE Plasma Version: 5.23.80
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.14.2-1-default (64-bit)
Graphics Platform: Wayland

ADDITIONAL INFORMATION
This does not only affect Kickoff launcher, but also every other menu I tested.
Comment 1 Patrick Silva 2021-09-17 19:58:43 UTC
Can confirm on Arch Linux running Plasma 5.23 beta and on neon unstable.
Comment 2 nbgyan 2021-09-20 21:52:14 UTC
I only recently decided to switch to Wayland for a test drive and I can confirm this is true.
Comment 3 Nate Graham 2021-09-21 22:10:34 UTC
Can confirm.
Comment 4 Till Schäfer 2021-10-14 13:31:40 UTC
The same is true for applications launched via shortcuts or krunner.
Comment 5 Nate Graham 2021-10-14 14:38:32 UTC
Yeah, those are separate issues which will need to be fixed separately.
Comment 6 Till Schäfer 2021-10-14 14:51:46 UTC
(In reply to Nate Graham from comment #5)
> Yeah, those are separate issues which will need to be fixed separately.

should I open separate bug reports for them or should we track them all here?
Comment 7 Nate Graham 2021-10-14 15:07:45 UTC
Separate bug reports please, and then we can relate them with the "See also" field so they don't get lost. Looks like we already have a bug report about apps launched via global shortcuts though: Bug 417087. So we just need one for KRunner.
Comment 8 Till Schäfer 2021-10-14 16:00:42 UTC
Bug 443726 -> KRunner
Comment 9 Patrick Silva 2022-05-12 10:30:57 UTC
On my neon unstable, launch feedback is working with apps started via kickoff or krunner. \o/

Operating System: KDE neon Unstable Edition
KDE Plasma Version: 5.24.80
KDE Frameworks Version: 5.94.0
Qt Version: 5.15.3
Graphics Platform: Wayland
Comment 10 Nate Graham 2022-05-12 13:16:38 UTC
Me too, can confirm that! I bet dollars to donuts that it was fixed by https://invent.kde.org/plasma/kwin/-/merge_requests/2302.
Comment 11 Aleix Pol 2022-05-13 14:52:01 UTC
:D how many dollars? 💵 💵 💵
Comment 12 Nate Graham 2022-05-13 15:00:46 UTC
Enough to buy donuts, clearly!