Bug 442355 - Window Decorations Titlebar Buttons Issue in Sidebar view after KDE 5.86 upgrade
Summary: Window Decorations Titlebar Buttons Issue in Sidebar view after KDE 5.86 upgrade
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: kcm_kwindecoration (show other bugs)
Version: 5.22.5
Platform: Other Linux
: NOR normal with 21 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 443677 444370 445003 455611 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-09-12 21:12 UTC by Kan
Modified: 2022-06-21 20:57 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.23


Attachments
Windows Decorations Titlebar Buttons config screen w circled issues (118.62 KB, image/png)
2021-09-12 21:12 UTC, Kan
Details
screenshot of "Titlebar buttons" tab with the problem (circled) (144.18 KB, image/png)
2021-10-13 17:39 UTC, Andrei Rybak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kan 2021-09-12 21:12:30 UTC
Created attachment 141501 [details]
Windows Decorations Titlebar Buttons config screen w circled issues

SUMMARY
After upgrading both my systems today, two different Arch distros, Garuda and EndeavourOS, the Window Decorations/Title Buttons control window is missing all the buttons accept the 'close window' button. If you add a button by dragging onto the taskbar, it adds the button, but you can't see it on the bar, nor can you then remove it. I have multiple minimize buttons on my system's windows decorations that I can't remove. 

I presented this issue on the EndeavourOS forum and one other person saw the missing buttons in his Window Decoration/Title Button config screen, but he could move and remove his invisible buttons. 

I have removed all theming, setting it back to basic Breeze standard theme, rebooted, updated system, rebooted. Issue still remains on both systems and distros.

STEPS TO REPRODUCE
1. Add a button to the Windows Decoration/Titlebar Buttons config screen. 
2. Notice you can't see the button, but it appears in every window's decorations.
3. Try and move over the area where the button should be in config screen but nothing happens, thus can't remove the button added in step 2. 

OBSERVED RESULT
See Attachment

EXPECTED RESULT
To see the buttons, and the ability to remove them. 

SOFTWARE/OS VERSIONS
Operating System: Garuda Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.2-zen1-2-zen (64-bit)
Graphics Platform: X11
Processors: 6 × Intel® Core™ i5-9600K CPU @ 3.70GHz
Memory: 15.5 GiB of RAM
Graphics Processor: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
ADDITIONAL INFORMATION
Comment 1 Zesko 2021-09-25 13:04:54 UTC
Me too.
https://forum.manjaro.org/t/kde-titlebar-buttons-missing-after-last-update/84051/3

Operating System: Manjaro Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Qt Version: 5.15.2
Kernel Version: 5.14.7-2-MANJARO (64-bit)
Graphics Platform: X11
Comment 2 Anton 2021-09-29 16:31:15 UTC
The same on KDE neon User Edition 5.22
---
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.86.0
Comment 3 K.J. Petrie 2021-10-03 16:23:32 UTC
In my case, on PCLinuxOS, the right-hand button isn't even in the display area of the window, appearing in the margin. The button on the left is at least in the right place, but only the left of two which should be there is displayed
Comment 4 K.J. Petrie 2021-10-05 15:12:09 UTC
Anyone seeing this on Intel graphics or are we all using nVidia or ATI?
Comment 5 K.J. Petrie 2021-10-06 10:22:31 UTC
Answer to my question at https://www.pclinuxos.com/forum/index.php/topic,156316.msg1343818.html#msg1343818.

The posts following show the problem is only present in Sidebar view with System Settings 5.22.5. With Systems Settings 5.21.5 it was present in both views, so it looks as if a fix has been made in Icon View which doesn't work in Sidebar view.

I note the reporter is also using Sidebar view so will take the liberty of editing the title if I can since it might be developers think this is something they've fixed and ignore it otherwise.
Comment 6 Anton 2021-10-06 10:28:11 UTC
Hi, K.J. Petrie.

Yes. Switching to "Icon View" fixes a problem.
Comment 7 K.J. Petrie 2021-10-06 10:34:15 UTC
Icon view and Window Decorations are both at v.1.0 in PCLinuxOS. I can't find a Help-> About in sidebar view.
Comment 8 Kan 2021-10-10 16:58:56 UTC
It appears in the new KDE 5.87.0 release, they have completely removed the option to configure Titlebar Buttons, unless they have moved it somewhere else. Can anyone confirm?
Comment 9 Kan 2021-10-10 17:03:01 UTC
Never mind my last comment, as the option to configure is still there in the new release, but the bug, unfortunately, still remains.
Comment 10 Ashwin 2021-10-11 09:19:58 UTC
I get the same behaviour.

Operating System: Arch Linux
KDE Plasma Version: 5.22.5
KDE Frameworks Version: 5.87.0
Qt Version: 5.15.2
Kernel Version: 5.10.72-1-lts (64-bit)
Graphics Platform: X11
Processors: 12 × Intel® Core™ i7-9850H CPU @ 2.60GHz
Memory: 31.1 GiB of RAM
Graphics Processor: Quadro RTX 3000/PCIe/SSE2
Comment 11 Andrei Rybak 2021-10-13 17:39:55 UTC
Created attachment 142410 [details]
screenshot of "Titlebar buttons" tab with the problem (circled)

With default settings, some buttons (minimize, maximize, close) are out of bounds (circled in red). Only part of minimize button is visible. The layout in preview does not correspond to actual buttons (circled in green).
Comment 12 80p3fy75dc 2021-10-14 12:05:53 UTC
Fixed for me on Arch Linux after updating to 5.23 today
Comment 13 Nate Graham 2021-10-14 23:32:27 UTC
Cannot reproduce, though I know I've seen other reports about this. Can you upgrade to Plasma 5.23 and see if it's still happening?
Comment 14 Nate Graham 2021-10-14 23:32:34 UTC
*** Bug 443677 has been marked as a duplicate of this bug. ***
Comment 15 Kan 2021-10-18 00:50:46 UTC
Confirmed, fixed for me after 5.23 update today. thanks.
Comment 16 Nate Graham 2021-10-18 00:58:20 UTC
Yay!
Comment 17 Nate Graham 2021-10-25 21:58:20 UTC
*** Bug 444370 has been marked as a duplicate of this bug. ***
Comment 18 Nate Graham 2021-11-08 20:37:24 UTC
*** Bug 445003 has been marked as a duplicate of this bug. ***
Comment 19 Nate Graham 2022-06-21 20:57:27 UTC
*** Bug 455611 has been marked as a duplicate of this bug. ***