Bug 441953 - '.gitmodules' on invent.kde.org
Summary: '.gitmodules' on invent.kde.org
Status: RESOLVED INTENTIONAL
Alias: None
Product: www.kde.org
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kde-www mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-03 16:16 UTC by Dominik Kummer
Modified: 2021-10-20 19:24 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dominik Kummer 2021-09-03 16:16:53 UTC
My gitlab account is not allowed to create nor push '.gitmodules' files.


STEPS TO REPRODUCE
1. Commit a file named '.gitmodules' locally.
2. git push

OBSERVED RESULT
remote: Audit failure - Commit 77b0c26b29bf6b78bad7c20877ae9025b4aff791 - Invalid filename: .gitmodules
remote: Push declined - commits failed audit
remote: Should the audit failures above mention issues regarding your name, please ensure that your Git username has been set to your full name.
remote: Please see https://git-scm.com/book/en/v2/Getting-Started-First-Time-Git-Setup for more details on ensuring Git has been fully configured.
remote: In the event that your full name has been set and is shown above as being rejected, please file a Sysadmin ticket at https://go.kde.org/systickets
To invent.kde.org:domson/kde-evolution.git
 ! [remote rejected] master -> master (pre-receive hook declined)
error: failed to push some refs to 'invent.kde.org:domson/kde-evolution.git'
Comment 1 Ben Cooksley 2021-09-03 20:00:25 UTC
This is intentional behaviour on the part of the Git hooks that operate on invent.kde.org.

.gitmodules files have resulted in developers breaking repositories in the past when they ended up committing the .git/ folder of the checked out submodule.

That required Sysadmin intervention to correct - with several carefully done force pushes from a mirror clone of the repository (a regular clone would fail terribly due to Git being confused)

Should you need to use .gitmodules please file a Sysadmin ticket, including the path to the repository you are looking to use it in as well as the justification for using .gitmodules and why other options are not possible.

Permission to use .gitmodules is not granted on a per account level - it is per repository.