Bug 441941 - Right-click on app in taskbar inconsistent behaviour
Summary: Right-click on app in taskbar inconsistent behaviour
Status: RESOLVED DUPLICATE of bug 417939
Alias: None
Product: kwin
Classification: Plasma
Component: appmenu (show other bugs)
Version: 5.20.5
Platform: Debian stable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-09-03 08:48 UTC by Marco Ambu
Modified: 2021-09-09 17:05 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Ambu 2021-09-03 08:48:18 UTC
SUMMARY
Inconsistent behaviour when right-clicking on an icon in the taskbar. Sometimes the pop-up menu is not shown, sometimes it is but it disappears as soon as I move the mouse on the action I want preventing me from clicking on it and execute the command.
The only way to make it work when the pop-up shows up is to wait for the thumbnail to go away.

STEPS TO REPRODUCE
1. right-click on an icon of a running app in the taskbar

OBSERVED RESULT
If I do not wait for the thumbnail of the window to show up, right-click does not show any context menu.
If I wait for the thumbnail of the window to show up, right-click will show a pop-up context menu with Close and other actions but as soon as I move the mouse over the action the pop-up disappears and I cannot click on anything.


EXPECTED RESULT
The pop-up menu is always shown when right-clicking on it. The pop-up menu never disappears when I move the mouse cursor over the item I want to click on. When I click on the item, the action is executed.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Debian 11, 5.10.0-8-amd64
(available in About System)
KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2

ADDITIONAL INFORMATION
I cannot take a screenshot for this use case, I'll see if I can record a video and attach it to this bug.
Comment 1 Nate Graham 2021-09-08 22:36:22 UTC
Are you using the Wayland session, by any chance?
Comment 2 Marco Ambu 2021-09-09 15:53:34 UTC
Yes, I am using wayland.
Comment 3 Nate Graham 2021-09-09 17:05:54 UTC
Aha, in that case this is already fixed in Plasma 5.23.

*** This bug has been marked as a duplicate of bug 417939 ***