Bug 441682 - Smudge Radius slider range doesn't change to range of diff smudge algo when reloading preset while option is selected
Summary: Smudge Radius slider range doesn't change to range of diff smudge algo when r...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Brush engines (show other bugs)
Version: 5.0.0-beta1
Platform: Appimage Linux
: NOR minor
Target Milestone: ---
Assignee: Tiar
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-29 03:21 UTC by tomtomtomreportingin
Modified: 2022-02-22 23:14 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tomtomtomreportingin 2021-08-29 03:21:32 UTC
SUMMARY
The old smudge algo has a Color Radius strength range of 0-300%, while the new algo has a range of 100%. When the user enables the new algo in Smudge Length and selects Smudge Radius option, then resets the brush, the slider still has a range of 0-100%. This happens in both directions, and I'm not sure if this impacts functionality of the brush itself. The range fixes itself when selecting a new option and going back to Smudge Radius.

STEPS TO REPRODUCE
1. Select i) Wet Knife.
2. Open Brush Settings, select Smudge Length option, enable new smudge algo.
3. Select Smudge Radius option.
4. Reset brush preset.

OBSERVED RESULT
The Smudge Radius slider still has a range of 0-100%.

EXPECTED RESULT
The Smudge Radius slider range should accommodate properly on reload.

SOFTWARE/OS VERSIONS
Linux/KDE Plasma: Debian sid
KDE Plasma Version: 5.21.5
KDE Frameworks Version: 5.83.0
Qt Version: 5.12.11 (Appimage)
Comment 1 Tiar 2022-01-13 15:21:40 UTC
Git commit 494d089943d545ee96c5f29763355c8df225cb48 by Agata Cacko.
Committed on 13/01/2022 at 14:46.
Pushed by tymond into branch 'master'.

Fix wrong color smudge radius range

Before this commit, if you:
1) took a brush like `i) Wet Paint Details`,
2) went to Smudge Length and enabled New Algorithm for smudging,
3) went to Smudge Radius (the slider range would be up to 100% because
that's the range for the new algorithm)
4) reset the brush
the range of the Smudge Radius slider would be still up to 100%
even though the old algorithm (used for that brush) is up to 300%
and should be restored when resetting.

This commit fixes this behaviour and now the range matches the
algorithm.

M  +2    -0    plugins/paintops/colorsmudge/kis_colorsmudgeop_settings_widget.cpp

https://invent.kde.org/graphics/krita/commit/494d089943d545ee96c5f29763355c8df225cb48
Comment 2 Tiar 2022-02-22 23:14:48 UTC
Git commit f49541f6d5738cfed63bfacd75c1a2c8c6930d2f by Agata Cacko.
Committed on 22/02/2022 at 22:51.
Pushed by tymond into branch 'krita/5.0'.

Fix wrong color smudge radius range

Before this commit, if you:
1) took a brush like `i) Wet Paint Details`,
2) went to Smudge Length and enabled New Algorithm for smudging,
3) went to Smudge Radius (the slider range would be up to 100% because
that's the range for the new algorithm)
4) reset the brush
the range of the Smudge Radius slider would be still up to 100%
even though the old algorithm (used for that brush) is up to 300%
and should be restored when resetting.

This commit fixes this behaviour and now the range matches the
algorithm.
(cherry picked from commit 494d089943d545ee96c5f29763355c8df225cb48)

M  +2    -0    plugins/paintops/colorsmudge/kis_colorsmudgeop_settings_widget.cpp

https://invent.kde.org/graphics/krita/commit/f49541f6d5738cfed63bfacd75c1a2c8c6930d2f