Bug 441581 - When "Amount" at ledgers get the focus by click, select the entire value
Summary: When "Amount" at ledgers get the focus by click, select the entire value
Status: RESOLVED FIXED
Alias: None
Product: kmymoney
Classification: Unclassified
Component: general (show other bugs)
Version: 5.1.2
Platform: Microsoft Windows Microsoft Windows
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KMyMoney Devel Mailing List
URL:
Keywords:
: 449549 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-26 18:10 UTC by Adilson Urso
Modified: 2022-02-04 06:48 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.3


Attachments
Amount selected (10.77 KB, image/jpeg)
2021-08-26 18:10 UTC, Adilson Urso
Details
attachment-28934-0.html (1.40 KB, text/html)
2021-08-26 19:38 UTC, Adilson Urso
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Adilson Urso 2021-08-26 18:10:24 UTC
Created attachment 141072 [details]
Amount selected

SUMMARY

When the Amount value is clicked at ledger, the entire value is selected.

STEPS TO REPRODUCE
1. 
2. 
3. 

OBSERVED RESULT


EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Jack 2021-08-26 19:11:22 UTC
It's easy enough to double (or triple?) click on the amount to select all of it.  Or else click at the beginning of the amount and drag to select all of it.
Comment 2 Adilson Urso 2021-08-26 19:38:52 UTC
Created attachment 141076 [details]
attachment-28934-0.html

Yes, it is. But is slower.
Kmymoney 5.0.6 was that way.

Em 26/08/2021 16:11, Jack escreveu:
> https://bugs.kde.org/show_bug.cgi?id=441581
>
> --- Comment #1 from Jack <ostroffjh@users.sourceforge.net> ---
> It's easy enough to double (or triple?) click on the amount to select all of
> it.  Or else click at the beginning of the amount and drag to select all of it.
>
Comment 3 Jack 2021-08-26 19:53:11 UTC
If you are saying  the behavior changed, please be more specific, as I don't recall any intentional changes in that area.  However, that type of behavior is more dependent on the underlying plasma and qt libraries than on KMyMoney itself.
Comment 4 Adilson Urso 2021-08-26 22:31:30 UTC
Yes
The behavior changed.
I think this start from 5.1...

I reinstalled the 5.0.6 to check and I confirmed the change.


Em 26/08/2021 16:53, Jack escreveu:
> https://bugs.kde.org/show_bug.cgi?id=441581
>
> --- Comment #3 from Jack <ostroffjh@users.sourceforge.net> ---
> If you are saying  the behavior changed, please be more specific, as I don't
> recall any intentional changes in that area.  However, that type of behavior is
> more dependent on the underlying plasma and qt libraries than on KMyMoney
> itself.
>
Comment 5 Thomas Baumgart 2021-08-27 16:07:42 UTC
Git commit f6b78dce235c2a869f2db28ccf04fa0b97031ea2 by Thomas Baumgart.
Committed on 27/08/2021 at 16:06.
Pushed by tbaumgart into branch 'master'.

Select amount upon focus in

M  +25   -8    kmymoney/widgets/amountedit.cpp
M  +5    -0    kmymoney/widgets/amountedit.h

https://invent.kde.org/office/kmymoney/commit/f6b78dce235c2a869f2db28ccf04fa0b97031ea2
Comment 6 Thomas Baumgart 2021-08-28 12:37:14 UTC
Git commit 763b941ca7e2d0d0e60540f3da8b7870c9e74015 by Thomas Baumgart.
Committed on 28/08/2021 at 12:36.
Pushed by tbaumgart into branch '5.1'.

Select amount upon focus in
FIXED-IN: 5.1.3

M  +25   -8    kmymoney/widgets/amountedit.cpp
M  +5    -0    kmymoney/widgets/amountedit.h

https://invent.kde.org/office/kmymoney/commit/763b941ca7e2d0d0e60540f3da8b7870c9e74015
Comment 7 Thomas Baumgart 2022-02-04 06:48:32 UTC
*** Bug 449549 has been marked as a duplicate of this bug. ***