Bug 441511 - Icons are larger than workspace borders in pager with multi-row/column desktop layout and very thin panel
Summary: Icons are larger than workspace borders in pager with multi-row/column deskto...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Plasma
Component: Pager (show other bugs)
Version: 5.22.4
Platform: OpenSUSE Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
: 441882 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-24 21:50 UTC by Lemuel Simon
Modified: 2022-02-21 18:08 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.24.2


Attachments
Annotated screenshot of the Pager Icon bug. (1.20 MB, image/png)
2021-08-24 21:50 UTC, Lemuel Simon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lemuel Simon 2021-08-24 21:50:42 UTC
Created attachment 141022 [details]
Annotated screenshot of the Pager Icon bug.

SUMMARY
With the recent update of KDE Frameworks to 5.85, icons in the Pager grew larger than the borders of each workspace button. Currently my panel is 32px tall, on a 1366x768 Laptop display. There is a regression on the scaling of icons in the Pager alone; it doesn't seem to affect other widgets (System Tray,Icon-only Task Manager). I have attached an image with the bug.

STEPS TO REPRODUCE
1. Update KDE Frameworks to 5.85
2. Start Plasmashell
3. Observe bug.

OBSERVED RESULT
Icons in the Pager grew larger than the borders of each workspace button.

EXPECTED RESULT
Icons in Pager scale properly and remain within the borders of the displayed windows in the Pager.


SOFTWARE/OS VERSIONS
Operating System: openSUSE Leap 15.3
KDE Plasma Version: 5.22.4
KDE Frameworks Version: 5.85.0
Qt Version: 5.15.2
Kernel Version: 5.3.18-57-default (64-bit)
Graphics Platform: X11
Processors: 4 × Intel® Core™ i5-3320M CPU @ 2.60GHz
Memory: 7.6 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4000

ADDITIONAL INFORMATION
I use openSUSE 15.3 Argon, that's how I got the latest KDE packages. However, the bug can be reproduced in Tumbleweed according to this post: https://old.reddit.com/r/kde/comments/p82p2s/icons_inside_workspace_pager_is_bigger_than_each/

I have tried removing and adding the pager, as well as restarting the system (if logging out wasn't enough). No change.
Comment 1 Nate Graham 2021-09-02 17:57:27 UTC
*** Bug 441882 has been marked as a duplicate of this bug. ***
Comment 2 Nate Graham 2022-02-21 18:08:18 UTC
Fixed by Fushan Wen with https://invent.kde.org/plasma/plasma-desktop/-/commit/695f5f58a5fdf7285707e2bb1aeb6b94c64a6ce6 in Plasma 5.24.2!