Bug 441469 - Kontact(and Kmail also) quit after clicking OK in add ID
Summary: Kontact(and Kmail also) quit after clicking OK in add ID
Status: REPORTED
Alias: None
Product: kontact
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Debian stable Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2021-08-24 08:57 UTC by Michael Grosskopf
Modified: 2021-11-06 07:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
valgrind result (1.14 MB, text/plain)
2021-11-06 07:43 UTC, Michael Grosskopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Grosskopf 2021-08-24 08:57:02 UTC
SUMMARY


STEPS TO REPRODUCE
1. Click on Settings
2. Configure Kmail
3. Select Identities 
4. any action filling the form
5. click add 

OBSERVED RESULT
The application-window closes eite when using kontact or kmail.
There is no Error-Message, nothing visible with dmesg nor journalctl

EXPECTED RESULT
a successful configuration of the ID and using that ID for gmail activities.

SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: Linux 5.10.52-v7+ on Raspberry Pi 3B+
(available in About System)
KDE Plasma Version: 5.14.5
KDE Frameworks Version: 5.54.0
Qt Version: 5.11.3

ADDITIONAL INFORMATION
When exporting the ID data I see that the identity for gmail is already present. In the application it is not showing up. There is only one ID, an aol account, that can receive but not send.
Sometimes at program start there is a message that kontact resp. kmail cannot connect to gmail.

There are no further issues on this machine. All further programs are working flawlessly.
This Raspberry is connected to two USB-drives
it is (via WiFi) samba-server. webserver with nginx, accessible via ddns, ssh, vnc, TeamViewer Host, runs php7, mysql, MQTT.
It is stable, auto-updating, doing daily auto backup, runs 24/7. It is powered via stepdown from my 24V DC emergency power-supply, so even does not stop at poweroutages. 
Cooling (running on python) fan keeps temperature below 60 C
Python 3 is running home-automation as service
CPU Usage below 40%, RamUsage below 70%, Swa[ Usage  below 45%
Comment 1 Michael Grosskopf 2021-08-24 09:10:37 UTC
This seems to be a developing story. Immediately after posting the bug-report a popup informed me that there are nnn mails in my google account. That account was not appearing in Kontact since an update a few months ago. So I opened Kontact and voilà the account is there. 

My archive -located on one of the USB-drives- disappeared, probably due to changed permission settings there.
I will do some more tests and will update my report asap.

keep looking up
Comment 2 Michael Grosskopf 2021-08-24 09:19:11 UTC
Although I can receive mails from my Google-mail account now, it it still not possible to add my ID for Google. The Program window closes without any further information.
Comment 3 Michael Grosskopf 2021-08-26 13:38:53 UTC
removed:
akonadi, kmail, kontact
~/config/arkonadi
~/local/akonadi
reinstalled kmail.
Same result as mentioned before.
After any effort to modify the only identity (I did not configure that, it is there when I open kmail settings) the program clses without error,
Cannoy connect to  the sole configured account.
Message: SASL(-4): "no mechanism available: No worthy mechs found"
Comment 4 Michael Grosskopf 2021-08-31 03:37:27 UTC
As mentioned before, this is a developing story. Kontact and kmail are not supported  for arm anymore. No sources available. 
Since I found the answer, no further action is required in that matter. 

I changed to 64 bit version on Raspberry 3B+.
During setup I encountered some complications. 
Zram-tools is not working satisfying in my setup. 
Zram by novaspirit is working fine.
Chromium-browser reacts crisp now, but was hanging without /usr/bin/zram.sh. 
Kmail is working on plasma desktop, but 
kontact is freezing within seconds after start. 
When starting kontact from konsole a message appears: ~/.local/kontact/kontact-.rc not found, but kontact is fully functional in LX... desktop. I will wait a couple of weeks. Possibly updates will solve this issue soon. 
If not, I will send a new bug report.
Comment 5 Michael Grosskopf 2021-08-31 04:15:20 UTC
sorry
~/.local/kontact/kontact-.rc  is wrong, it is
~/.local/kontact/default-.rc
Comment 6 Michael Grosskopf 2021-09-16 07:23:46 UTC
Dear developers,
not clear whether you have seen the messages about problems with kontact/kmail.
It would be good to hearing, that you have noticed them and it would even better hearing, that you are working on them. 
Please drop at least one line
Best regards
Comment 7 Michael Grosskopf 2021-11-06 07:43:38 UTC
Created attachment 143271 [details]
valgrind result