Bug 441447 - Consider reverting replacement of zoom buttons with background color selector
Summary: Consider reverting replacement of zoom buttons with background color selector
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: usability
: 443281 (view as bug list)
Depends on:
Blocks:
 
Reported: 2021-08-23 19:59 UTC by Aurelien Gateau
Modified: 2022-02-14 17:53 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04


Attachments
These buttons (14.38 KB, image/png)
2021-10-17 15:52 UTC, Nagy Tibor
Details
Fit, Fill 100% size buttons (6.25 KB, image/png)
2021-10-17 16:00 UTC, Satyam
Details
Revert patch (73.25 KB, patch)
2021-11-03 15:56 UTC, Martin Sandsmark
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aurelien Gateau 2021-08-23 19:59:27 UTC
SUMMARY

Since https://invent.kde.org/graphics/gwenview/-/merge_requests/54, the one-click zoom buttons of the status bar have been replaced with a combobox, and the freed space used to add a background color selector.

Following comments from Nate blog post about this change (https://pointieststick.com/2021/07/02/this-week-in-kde-gwenview-and-more/comment-page-1/#comment-22661), I am filling this bug report because I think this change makes the experience of most users worse.

As I wrote in one of the comments, switching between 100% & fill is something I do sometimes multiple times per image. Changing the background color… I just don’t. If the option really has to be given a quicker access, I think the context menu would be more appropriate.

The MR implementing this feature mentions the use case of browsing icons, and I can see how it can be useful in this situation, but I believe this is a minority use case compared to browsing pictures.

SOFTWARE/OS VERSIONS

Linux/KDE Plasma: 21.08
KDE Plasma Version: 21.08
Comment 1 Nate Graham 2021-08-23 20:17:43 UTC
CCing Noah, who made this change.

Note that Aurelien is the creator and former maintainer of Gwenview. :)
Comment 2 Nate Graham 2021-08-23 20:19:03 UTC
To be fair, I think I was actually the one who recommended this placement, and the original implementation was with a two-position toggle button on the toolbar.
Comment 3 Aurelien Gateau 2021-08-23 21:14:35 UTC
> Note that Aurelien is the creator and former maintainer of Gwenview. :)

Also note that I do not expect any special treatment just because I am the former maintainer :) Those who do the work *nowadays* get to decide.
Comment 4 Noah Davis 2021-08-24 00:02:37 UTC
(In reply to Nate Graham from comment #1)
> CCing Noah, who made this change.

I'm not that attached to the change.

> Changing the background color… I just don’t.

I suppose it depends on what kinds of images you frequently look at. With images that have transparent parts or consist of mostly one color, background color may have to be changed frequently and opening the settings dialog every time is just too slow.

> If the option really has to be given a quicker access, I think the context menu would be more appropriate.

I suppose that would be fine. It's less discoverable, but at least it's better than a settings dialog.
Comment 5 Aurelien Gateau 2021-08-28 09:05:47 UTC
Sounds good to me.
Comment 6 Nate Graham 2021-10-04 23:54:12 UTC
*** Bug 443281 has been marked as a duplicate of this bug. ***
Comment 7 Krystian 2021-10-07 21:43:21 UTC
Just wanted to say that I really miss those zoom buttons. Personally, I've used them a lot. The current solution is slow and kind of finicky.
Comment 8 Satyam 2021-10-16 20:08:42 UTC
Gwenview is a lot less handy for me with those buttons gone.
Comment 9 Michael 2021-10-17 11:25:36 UTC
(In reply to Satyam from comment #8)
> Gwenview is a lot less handy for me with those buttons gone.

"those buttons" are which buttons?
Comment 10 Nagy Tibor 2021-10-17 15:52:34 UTC
Created attachment 142533 [details]
These buttons

(In reply to Michael from comment #9)
> (In reply to Satyam from comment #8)
> > Gwenview is a lot less handy for me with those buttons gone.
> 
> "those buttons" are which buttons?
Check my attachment.
Comment 11 Satyam 2021-10-17 16:00:40 UTC
Created attachment 142534 [details]
Fit, Fill 100% size buttons
Comment 12 Satyam 2021-10-17 16:05:59 UTC
(In reply to Nagy Tibor from comment #10)
> Created attachment 142533 [details]
> These buttons
> 
> (In reply to Michael from comment #9)
> > (In reply to Satyam from comment #8)
> > > Gwenview is a lot less handy for me with those buttons gone.
> > 
> > "those buttons" are which buttons?
> Check my attachment.

Not the background color buttons, the "Fit, Fill, 100%" view size buttons.  It's surprisingly effort-full to have to go to the drop down because I use those almost every time I look at an image.

I added an attachment of a locally modified Gwenview, that re-added those buttons and also kept the background color buttons.  They all fit pretty well. Though while I like the ability to choose background color, that's a setting I set once and rarely revisit again.
Comment 13 Michael 2021-10-17 20:26:43 UTC
(In reply to Satyam from comment #12)
> (In reply to Nagy Tibor from comment #10)
> > Created attachment 142533 [details]
> > These buttons
> > 
> > (In reply to Michael from comment #9)
> > > (In reply to Satyam from comment #8)
> > > > Gwenview is a lot less handy for me with those buttons gone.
> > > 
> > > "those buttons" are which buttons?
> > Check my attachment.
> 
> Not the background color buttons, the "Fit, Fill, 100%" view size buttons. 
> It's surprisingly effort-full to have to go to the drop down because I use
> those almost every time I look at an image.
> 
> I added an attachment of a locally modified Gwenview, that re-added those
> buttons and also kept the background color buttons.  They all fit pretty
> well. Though while I like the ability to choose background color, that's a
> setting I set once and rarely revisit again.


I tell why the background color bar is sensless, somebody make a comment about but also quiet sensless, when you zoom a picture in you don't see bacground and when not you probably chose fot or fill, means there are a couple of milimeters around the image nothing more ... for that we got the price of a "limping" interface to pay, its performance is horrible and it doesn't close when you hit the x button on top
Comment 14 Krystian 2021-10-17 20:57:26 UTC
(In reply to Michael from comment #13)
> I tell why the background color bar is sensless, somebody make a comment
> about but also quiet sensless, when you zoom a picture in you don't see
> bacground and when not you probably chose fot or fill, means there are a
> couple of milimeters around the image nothing more ... for that we got the
> price of a "limping" interface to pay, its performance is horrible and it
> doesn't close when you hit the x button on top
 
Background color is probably useful for viewing icons with transparency. 
Still, gimping one workflow to enable another is not the way to go. Especially, considering how many people actually need to open icons vs those who view photos.


The current implementation is really finicky. Sometimes scrolling down takes you to "Fill" but other times to "400%". Then you scroll down again and it something like "95%". And then you scroll again and it's "100%" which is basically "Fill" again.
I keep second guessing myself and it's really not a good experience.
Comment 15 Satyam 2021-10-17 22:57:46 UTC
The modified version my son did looks and works great for me. Having both the colors and the Fit Fill 100% buttons doesn't strike me as cluttered or anything. How about both?
Comment 16 Bug Janitor Service 2021-10-25 15:50:25 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/gwenview/-/merge_requests/113
Comment 17 Martin Sandsmark 2021-11-03 14:49:38 UTC
Apparently I wasn't the only one tearing my hear out over this change.

My idea (before looking for open bugs) was to turn the bottom bar into just another editable toolbar, and add the items currently there as default actions.

(I also don't think a combobox which automatically commits changes when moving the mouse over it is the right control for zoom level, though that's another discussion.)
Comment 18 Martin Sandsmark 2021-11-03 15:27:33 UTC
FWIW, in case anyone else just want to quickly revert, last good commit was 976978b9eef6b809afc551289bf19d04c8ff094c (so if anyone uses the gwenview-git package on archlinux just add "#commit=976978b9eef6b809afc551289bf19d04c8ff094c" at the end of the source line).
Comment 19 Nate Graham 2021-11-03 15:52:28 UTC
(In reply to Martin Sandsmark from comment #17)
> Apparently I wasn't the only one tearing my hear out over this change.
> 
> My idea (before looking for open bugs) was to turn the bottom bar into just
> another editable toolbar, and add the items currently there as default
> actions.
That seems like a reasonable idea to me.
Comment 20 Martin Sandsmark 2021-11-03 15:56:29 UTC
Created attachment 143172 [details]
Revert patch

Just a quick and dirty patch (wasn't straight forward because of the repo-wide code reformatting) if anyone else wants current master but with the old zoom buttons.
Comment 21 Bug Janitor Service 2022-01-10 23:35:32 UTC
A possibly relevant merge request was started @ https://invent.kde.org/graphics/gwenview/-/merge_requests/130
Comment 22 Felix Ernst 2022-01-14 12:08:52 UTC
Git commit 209c7284b0daea1b750e1cd01d4ee80dd050d172 by Felix Ernst.
Committed on 14/01/2022 at 12:08.
Pushed by felixernst into branch 'master'.

Remove background color chooser widget

In e6241375e3ffecf0bfc0973b5e00dd193183eabb actions were added to
Gwenview which allowed easy changing of the background color. As
part of this change a widget was added to the status bar which
contains these new actions.

This commit removes the widget again while keeping the actions to
quickly change the background color of the view available both from
the menu bar and from the right-click context menu.

Having these actions always visible on the status bar doesn't seem
necessary because users generally seem to not be too interested in
switching the background color frequently.

This commit is kind of a requirement for adding other actions to
the status bar instead which users are vocally more interested in
having.

Most of the added lines were just moved from the widget class to the `documentviewcontroller`.

M  +5    -5    app/gvcore.cpp
M  +0    -5    app/viewmainpage.cpp
M  +0    -1    lib/CMakeLists.txt
D  +0    -283  lib/backgroundcolorwidget/backgroundcolorwidget.cpp
D  +0    -45   lib/backgroundcolorwidget/backgroundcolorwidget.h
M  +1    -1    lib/documentview/documentview.cpp
M  +4    -3    lib/documentview/documentview.h
M  +109  -58   lib/documentview/documentviewcontroller.cpp
M  +0    -3    lib/documentview/documentviewcontroller.h
M  +7    -7    lib/gwenviewconfig.kcfg

https://invent.kde.org/graphics/gwenview/commit/209c7284b0daea1b750e1cd01d4ee80dd050d172
Comment 23 Nate Graham 2022-02-14 17:53:19 UTC
Git commit a94fe7dde79fe1a3813564989faf55d5facaefc5 by Nate Graham, on behalf of Felix Ernst.
Committed on 14/02/2022 at 17:53.
Pushed by ngraham into branch 'master'.

Add a "Fit" button to the status bar

![2021-10-25_17-42-52](/uploads/07657e3e17892c39c02b183743725b12/2021-10-25_17-42-52.mp4)

The zoom actions for "Fit", "Fill" and "100%" were recently moved
from status bar to a common popup also available on the status bar
in 2c829f4e.
There was some criticism of this change because users found it
unnecessarily cumbersome that they now needed an extra click to
invoke these common actions.

This commit re-adds a "Fit" button on the status bar. It is a
toggle button and unchecking it will switch to "100%".

There is some criticism that this commit doesn't also re-add the
"Fill" and "100%" buttons. I will explain my reasons for not
adding them but this doesn't reflect a reached consensus and can
therefore not be a final decision.

I am interested in merging this as it is anyway because nobody
was against adding a "Fit" button.

The reasons why this commit re-adds a "Fit" button but neither a
"Fill" nor "100%" button are as follows:

"Fit" is the default way to view an image in Gwenview. It allows
users to get the full picture which in many cases is the most
important way to view an image. Whenever any zoom changes were done
this button will allow to quickly jump back to seeing the whole
image.

Zooming to "100%" is considered to be a lot less useful in many
situations. 1. The zoom value is identical to Fit for images
smaller than the view area. 2. Because of the previous, having
both a "100%" and "Fit" button can be confusing because changing
between them does seemingly nothing even though having these
buttons side by side implies that it would. 3. For pictures made
with typical cameras/phones nowadays 100% zoom is very zoomed in
and not automatically any more useful than e.g. 50% zoom.
For these reasons no "100%" button is added by this commit.
However the "Fit" action always worked in a way that unchecking it
zooms to 100% so zooming to 100% is now also only one click away
even though no explicit "100%" button is added.

Concerning the "Fill" action: I didn't see a lot of comments of
people being bothered by its removal from the status bar. Using it
might be an aquired taste and there might be some people that
use it a lot but it doesn't seem like it is very popular currently.
Users are encouraged to add a "Fill" button to their personal
toolbar or to "scroll down" on the new ZoomComboBox.

FIXED-IN: 22.04

cc @ndavis, @ngraham

M  +8    -0    lib/zoomwidget.cpp

https://invent.kde.org/graphics/gwenview/commit/a94fe7dde79fe1a3813564989faf55d5facaefc5